Wireless Wake on LAN traffic not passing?

  • 1
  • Question
  • Updated 1 year ago

We have a developer creating an application which uses roaming/ruggedized PC's on forklifts.  When they unplug the forklift to charge, the PC goes to sleep after a while.  When they plug the forklift back in, the PC does not wake up.  They've checked and there are no settings to tell it to do so.  So, that is the background for why I'm asking this question: does Wake on LAN traffic get filtered out?  I don't know where to look to see if it may be.  (Sorry, I'm not very good with Aerohive / wireless in general.)  These are AP1130's.  I set them up (i.e., their network policy, etc.) but a lot of the traffic filters and such that are in there I did not set up; they were already there and I re-used them).  As a test, they have two wireless laptops sitting next to each other, both attached to the wireless network in question.  One is put to sleep and the other sends the WOL request, and it never works.

Thoughts?  Thanks in advance for any help!

Bob

Photo of Bob Reichard

Bob Reichard

  • 4 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Bill W.

Bill W.

  • 222 Posts
  • 35 Reply Likes
Wake on Wireless LAN is not as straight forward as Wake on LAN. There are a lot of moving parts. What OS are the laptops running? Do you have WNIC configured to bring the device out of standby (this is disabled by default on Windows devices)? Is the WNIC integrated into the motherboard? Are the WNIC drivers updated? Is WoLAN (and WoWLAN if a setting) enabled in the BIOS? Is WoWLAN supported and enabled on the WNIC (I know Intel WNICs have a setting for this, and it should be enabled by default)?

Here's an old article, but it has some good info on WoWLAN:
http://revolutionwifi.blogspot.com/2010/11/wake-on-wireless-lan.html

Also, I would double-check the BIOS setting of the PCs. I know Dell laptops have a setting in the BIOS to "Wake on AC", and this has been in there for many years. So when you are checking the BIOS for a WoLAN/WoWLAN setting, check for a Wake on AC setting too. If it has it, that would be the better way to go anyway.
Photo of Bob Reichard

Bob Reichard

  • 4 Posts
  • 0 Reply Likes
Thanks Bill.  I will pass this on and get back to you ASAP.  Thanks again!
Photo of Bob Reichard

Bob Reichard

  • 4 Posts
  • 0 Reply Likes
I'm sorry for the delay.  I haven't heard back from the developer.
Photo of Bob Reichard

Bob Reichard

  • 4 Posts
  • 0 Reply Likes

Bill W.,

He's asking if wireless broadcast frames are being blocked.  I don't know how to tell.


Thanks,

Bob