vmware tool fails on OVA image in HM virtual machine 8.2.r1

  • 1
  • Question
  • Updated 2 weeks ago
there is an option in 8.2.r1 to install vmware tools:

1) Network Settings and Tools
12) VMware Related Options
2) Install VMware Tools
But installation fails - attaching both pictures ....
Photo of MST


  • 152 Posts
  • 3 Reply Likes

Posted 2 weeks ago

  • 1
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2486 Posts
  • 448 Reply Likes

There are two issues here. 

The first issue is the error: 

"* Unable to install VMware Tools. An error occurred while trying to access image 
file "/usr/lib/vmware/isoimages/linuxPreGlibc25.iso" needed to install 
VMware Tools: 2 (No such file or directory)." 

This is resolved by following the instructions at https://kb.vmware.com/s/article/2147454 and occurs because the version of VMware Tools you are trying to install built against a version of glibc that is not compatible with CentOS 6.

The second issue is a cosmetic-only problem where HM Classic can report failure where there is a actually a successful installation with recent versions of VMware Tools due to a difference in return code. 

We will correct the second cosmetic issue with a future update to HM Classic. 

You need to use the linuxPreGlibc25.iso per the VMware instructions for HM Classic and then, despite a failure being reported, successful installation should occur.


Photo of MST


  • 152 Posts
  • 3 Reply Likes
Great, looks like following the link  https://kb.vmware.com/s/article/2147454 fixes the vmware tools installation. I can see now at vmware tools installed: YES but there is tool number version.

  I have just copied linuxPreGlibc25.iso from 10.0.1 tools and installation went Succesful. 

Upgrade went as well, after  changing linuxPreGlibc25.is ti linux.iso 

Thank you so much Nick for your help here. MST