VLAN tagging

  • 1
  • Question
  • Updated 4 years ago
  • Answered
I have two SSIDs running on my APs. The first SSID is configured for VLAN 1 and is the default VLAN on my network. The second SSID is configured to use VLAN 3 and is used for IT only. I have my APs connected to trunk ports on the wired switch that expect to see untagged traffic (from the AP) on VLAN 1 and tagged traffic (from the AP) on VLAN 3. Connections to the SSID on VLAN 1 work fine, but I get no DHCP or connectivity to VLAN 3 when using that SSID.
Photo of Brian Judd

Brian Judd

  • 4 Posts
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 1
Photo of Andrew Garcia

Andrew Garcia, Official Rep

  • 368 Posts
  • 120 Reply Likes
Did you try the VLAN probe to see whether the AP sees VLAN 3 and can obtain a DHCP address from it? Tools > VLAN Probe > VLAN Range 1-3.

Also, it would help if you could post a screen cap of your config for the IT SSID (SSID and user profile).

 
Photo of Brian Judd

Brian Judd

  • 4 Posts
  • 0 Reply Likes
I tried the VLAN Probe, but it doesn't even respond on VLAN ID 1 which is working just fine???



Here are my SSID and User Profiles.



Photo of Brian Judd

Brian Judd

  • 4 Posts
  • 0 Reply Likes
Just to clarify, I have a single wired connection from the AP's eth0 to my switch.  The port on the switch is configured as a Trunk Port with VLAN 1 untagged and VLAN 3 tagged.
Photo of Andrew MacTaggart

Andrew MacTaggart, Champ

  • 483 Posts
  • 86 Reply Likes
What vlan are you using for the AP mgmt interface and the native vlan?

the native vlan must match your untagged vlan




Photo of Brian Judd

Brian Judd

  • 4 Posts
  • 0 Reply Likes
AP management interface is on the default VLAN 1 and is working properly (connected to our Hive Manager in cloud).  ie Native VLAN = untagged VLAN.
Photo of Carsten Buchenau

Carsten Buchenau, Champ

  • 356 Posts
  • 117 Reply Likes
Hi Brian,

Just to check: Did you make sure that VLAN 3 is also available on the Uplink on this Switch? You can also try this: Configure a free port on your switch with VLAN 3 untagged and connect a computer. Are you getting an IP address via DHCP?

For understanding: The VLAN probe tool is doing exactly this: It sends out a DHCP request and waits for an answer from a DHCP server. So if your VLAN is configured without DHCP server, with static IP address only, this tool won't help you.

carsten