VLAN reserverd for internal use?

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Hello,

I'm implementing a new WiFi network and I'm using Aerohive's switches for the first time. So far it seems to work flawlessly, however the customer for some extra VLAN's across the Aerohive switches and AP's. This VLAN range is between 4001 and 4015. However when I add these VLAN's on my trunks and upload the configuration to the AP's and switches. I get the error that the VLAN is reserved for internal use and I cannot use it. 

I cannot find a document which describers the VLAN's I can use. Does anyone know which VLAN's are reserved or unusable?
And is there a way to circumvent this? The organisation which realises these VLAN's is very slow and it can take weeks to change these VLAN numbers.

With kind regards,
Bart
Photo of Bart Hunik

Bart Hunik

  • 7 Posts
  • 1 Reply Like

Posted 4 years ago

  • 1
Photo of Sam

Sam

  • 120 Posts
  • 31 Reply Likes
The SR2024 switches require a block of 128 VLANs that are reserved for internal use. These VLANs must be reserved. By default, switches reserve VLANs 3967-4094. You can change the range of the device level by going to Configuration/Monitor > Devices > Switches > switch_name,  click 'modify', expand Reserved VLAN Settings, and enter the start of the block of VLANs that you want to reserve in this field.
Photo of J. Goodnough

J. Goodnough, Champ

  • 266 Posts
  • 32 Reply Likes
Might not be the right place to discuss this, but what are the reserved VLANs used for?
Photo of Sam

Sam

  • 120 Posts
  • 31 Reply Likes
It's for proprietary cooperative-control stuff. Mainly to avoid duplicate MAC learning.
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
Adding to Sam's excellent answer, please be aware that we are adding new capabilities and features to HiveOS in future releases that may require a larger range of reserved VLANs. I suggest if at all possible you reserve a block of 255 contiguous VLANs now for future-proofing.
Photo of Bart Hunik

Bart Hunik

  • 7 Posts
  • 1 Reply Like
Hi Sam,

This was exactley the option I was looking for, You saved my day. I will also reserve more VLAN's (255) to be future-proof as according to Mike. Thanks again for the support.

With kind regards,
Bart
Photo of Bryan Tetlow

Bryan Tetlow

  • 78 Posts
  • 2 Reply Likes
I've recently updated to 6.4R1a, and with this firmware, ALL of my SR2148's are generating a warning that they cannot reserve VLAN 3967.

I do not get this warning with my SR2024's or SR2124's.

I looked at the existing VLANS, and only "my" VLANS are listed in that list.

Is this a false positive warning, or should in fact the listed range 3967-4094 be reserved someplace visible to me and it's not?

(edit)
I have confirmed that this particular vlan *IS* listed at the switch level, so I don't really know WHAT it's complaining about.
(Edited)
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
Bryan,
I  had an engineer try reproducing what you've described, but we could not. Obviously there must be a misunderstanding in what you are describing.

I suggest you contact your reseller or Aerohive technical support, who should be able to get a better understanding and either explain what you have done wrong or to file a bug on your behalf.
Photo of BJ

BJ, Champ

  • 374 Posts
  • 45 Reply Likes
Mike, 
I was advised by tech support to upgrade one of our SR2148Ps to 6.4r1d.2111. Since we have two in this facility, I upgraded both over the weekend. I am now receiving the same error Bryan reported. Ironically, the switch reporting the error is not the same switch I opened the ticket on.

Best,
BJ 


Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
BJ,
You can change the range by going to Configuration/Monitor > Devices > Switches > switch_name,  click 'modify', expand Reserved VLAN Settings, and enter the start of the block of VLANs that you want to reserve in this field.

Does this not work for you?
(Edited)