Very low data rates on OS X

  • 1
  • Question
  • Updated 4 years ago
  • Answered
I'm seeing very low Tx rates when I option-click the wifi menu bar icon under Yosemite. At home, with one Airport Extreme servicing the whole house, I see 300Mbps.

At school, where we have 9 APs around the building, I'm seeing data rates between 12 and 54Mbps - even when I'm parked right next to the AP.

I would appreciate any advice available on where to start tweaking or debugging to solve this.

Thanks,
Fraser
Photo of Fraser Speirs

Fraser Speirs

  • 13 Posts
  • 2 Reply Likes
  • optimistic

Posted 4 years ago

  • 1
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
Are you sure you're using WPA2 and not WPA and have left WMM enabled?
Photo of Fraser Speirs

Fraser Speirs

  • 13 Posts
  • 2 Reply Likes
NIck, I was using WPA2 but I had somehow got WMM turned off. I've rectified that and will test things out on Monday. Thanks!
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
Cool! The 802.11n specification requires devices to support 802.11e, of which WMM is a subset, in order to use HT data rates.

(WMM's TID field is a requirement of aggregation mechanisms, including block ACK, that facilitate 802.11n's HT rates.)
(Edited)
Photo of Manoah Coenraad

Manoah Coenraad, Champ

  • 72 Posts
  • 67 Reply Likes
Hello Fraser,

Do you use a B/G/N Radio profile? If you use a B/G Radio profile the maximum speed then is 54Mbps. 
Photo of Fraser Speirs

Fraser Speirs

  • 13 Posts
  • 2 Reply Likes
Just to follow up, I've re-enabled WMM but I'm still only seeing 130Mbps Tx rates, even with clear air between the AP and my machine. Anything else I could look at?
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
Yup, you want to make sure a client has connected at 5 GHz and not 2.4 GHz and the radio profile gives the appropriate channel width to give higher data rates.

Do you have band steering enabled?
(Edited)
Photo of Fraser Speirs

Fraser Speirs

  • 13 Posts
  • 2 Reply Likes
I have AP330s which I thought don't support 40MHz channels. I do have band steering enabled in the "Balance Band Use" setting, looking for an 80/20 split of 5GHz to 2.6GHz clients. Also, using Airtime-based load balancing mode.
Photo of Andrew Garcia

Andrew Garcia, Official Rep

  • 368 Posts
  • 120 Reply Likes
The AP330/350 does support 40 MHz channels on 5 Ghz. You just need to assign a radio profile to the 5 GHz radio with 40 Mhz channels assigned.  
Photo of Sam

Sam

  • 120 Posts
  • 31 Reply Likes
Additionally, if your Mac is  <= 2010 then 130 is the limit the wlan nics support. If you have a 2011 or newer, then you should have support for higher MCS indices.
(Edited)
Photo of Fraser Speirs

Fraser Speirs

  • 13 Posts
  • 2 Reply Likes
Just to follow up, I think we're in good shape now. I've re-enabled WMM and enabled 40MHz channels on 5GHz. I'm seeing the full data rates that I would expect now. Thanks all for the help.
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
I do think there should be some information about the impact of disabling WMM in the UI of HiveManager so that it's not quite so easy to fall in to this trap. I'll suggest this during the forthcoming beta process.