Unable to give CWP a static IP address

  • 1
  • Question
  • Updated 5 years ago
  • Answered
Hi,

I'm trying to get a CWP to use just a single IP address instead of the usual 1.1.1-16.1 1.1.101-116.1 addresses. I've unticked the 'use default network settings' box on the option advanced config for the CWP in question and used a 172.16.x.x address with a /24 mask.

After uploading the config and rebooting the APs, the CWP still uses the default range. Are there any specific criteria I should be adhering to?

Thanks
Photo of Terry Ip

Terry Ip

  • 8 Posts
  • 1 Reply Like

Posted 5 years ago

  • 1
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
Terry,
Which version of HiveManager are you using? Things have moved a little in the last couple versions. Could you supply screenshots of where you are trying to configure this?
Photo of Terry Ip

Terry Ip

  • 8 Posts
  • 1 Reply Like
This is on 5.1r5a.
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
Terry,
I just tried this on my own Hive (version 6.1r1), and it took the config successfully and behaved as expected.

I see two possibilities. First, and what I hope to be the real explanation your setup is not behaving as desired, I noticed you were using the same address for all four interfaces. When I tried using your addresses on my setup, the client associated to the SSID, but the CWP never showed up. I then changed to use 172.16.50.2, 172.16.51.2, 172.16.53.2, and 172.16.54.2, respectively, and it began working as expected. [edit: I changed the addresses to be used after I reviewed the help files and saw that the examples all used unique addresses per interface. I didn't get a chance to talk to engineering to find out for sure why, but suspect its used to help us steer traffic back out the correct interface per client]

Second, it's possible there's a bug in 5.1r5a.

Please try changing to use different addresses for each interface and let us know the results.
Photo of Terry Ip

Terry Ip

  • 8 Posts
  • 1 Reply Like
Hi Mike,

I've tried setting the interfaces to 4 different addresses, and it's still using the default 1.1.x.1 addresses when the CWP presents itself. So it looks like it could be the second of your suggestions and a bug in 5.1r5a. Would you be able to try and replicate this in a lab environment before I look at getting a software update pushed out?

Thanks
Photo of Terry Ip

Terry Ip

  • 8 Posts
  • 1 Reply Like
Just re-reading your reply, I noticed that you were changing the 3rd octet in the address. I was changing the 4th octet in the address. Do the interface addresses have to be in separate subnets? If so, is there a reason for this?
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
Terry,
I have confirmed with some people who were with Aerohive back in 2007 that we do require each interface to be in a separate subnetwork.

The developer who originally implemented it is no longer with us and the fellow who maintains this area of code is on PTO this week so I can't get all the gory details, but I was told it's related to the walled garden support and the fact that originally we used to intercept the DHCP and DNS for each subnet, so we owned the network for each connection.
Photo of Terry Ip

Terry Ip

  • 8 Posts
  • 1 Reply Like
Hi Mike,

I've tried assigning 1.1.1.1, 1.1.2.1, 1.1.3.1 and 172.16.50.12 (I'm only concerned with the address for 802.11g connections), but I'm still only getting 1.1.x.1 for the CWP address in my browser.
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
Hmmm. Okay, silly question time: You DO have this checked, don't you?

Photo of Terry Ip

Terry Ip

  • 8 Posts
  • 1 Reply Like
Hi Mike,

I've got all 4 of those boxes checked.
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
Terry,
I'm sorry, but you've exhausted my ability to troubleshoot this. I suggest you contact your reseller or Aerohive support. I'm sure they'll get to the bottom of this with you in very short order.
Photo of Terry Ip

Terry Ip

  • 8 Posts
  • 1 Reply Like
Okay, it appears to be working now. Will need to do some more testing, but I'm not sure if it was because I had the Hive upgraded to 6.1r1 or that I used all class B addresses instead of a mix of class A and B.
Photo of Terry Ip

Terry Ip

  • 8 Posts
  • 1 Reply Like
Okay, I think I've got a little further with understanding this problem now. I've been playing around with different configurations and seem to have found something that may either be a bug or intentional for whatever reason.

Both my APs are statically addressed on subnet a.a.a.x/24. If I set eth0 on the CWP network settings, then the address when accessing the CWP is shown as whatever I set it to. If I change the eth0 to a different subnet so that I can use subnet a.a.a.x/24 on 802.11b/g/n instead, then it doesn't work.

So in essence, if the eth0 setting is set to a different subnet that the AP is on then the CWP doesn't present itself on the addresses I configure for it.

I also have one of the APs configured as a RADIUS server on subnet a.a.a.x/24.
Photo of Amanda

Amanda

  • 396 Posts
  • 25 Reply Likes
Thanks for the update on this Terry Ip.