Unable to find API Authorization Settings in HiveManager® Enterprise 6.4r1.Need help.

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Hey there. i am trying to enable Access to the HiveManager REST API.But i cant find API Authorization Settings in the HiveManager Settings as mentioned in the documentation.How to enable access.help me please.I neend to get data using rest api
Photo of Asad Rehman

Asad Rehman

  • 5 Posts
  • 2 Reply Likes

Posted 4 years ago

  • 1
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
Asad,
I am guessing that you have a HiveManager OnLine account, not using an on-premises HiveManager, correct? The REST APIs are not available on HMOL. 

I just checked with my peer PLM who owns HM, and we will be modifying the documentation to make this clearer.
Photo of Asad Rehman

Asad Rehman

  • 5 Posts
  • 2 Reply Likes
Hey Mike
Thank you for the reply. Yes I am using online account and i think this is the issue. I will contact to the person on-premises,will see if he is able to enable the access.
Kindly modify the documentation.
Thanks again for the reply.
Photo of Stephan Hughson

Stephan Hughson

  • 8 Posts
  • 2 Reply Likes
I'm trying to connect to the HiveManager API as well, specifically to https://hivemanager.XXXXX/hm/api/v1/devices using PHP code found on this forum.

I don't think the API is enabled / I haven't set up the right authentication. I've looked everywhere I can think of in the hivemanager web interface and can't find it. Am I looking in the wrong place? We're on 6.4r1.

Thanks for your help.
Photo of Asad Rehman

Asad Rehman

  • 5 Posts
  • 2 Reply Likes
Hey Stephan
API is only accessible when you enable API Access. First you have to enable API access in HiveManager Settings -> API Authorization Settings but it seems you are using online account so as @Mike mentioned above that the REST APIs are not available on HMOL,it can only be accessible on on-premises HiveManager. That is why you are unable to find API Authorization Settings in HiveManager Settings.
Photo of Stephan Hughson

Stephan Hughson

  • 8 Posts
  • 2 Reply Likes
Thanks for the quick reply. I have the on-premises HiveManager, pretty sure. We run it as a VM locally, it's not in the cloud or anything like that. I just can't find that setting anywhere!

Along the top when I login, I have Home, Dashboard, Monitor, Reports, Maps, Configuration, Tools.
I'm looking in Configuration (mostly).

I see Devices, Hives, Network Policies, SSIDs ... etc...  down the left side, then some more likely seeming ones under Advanced Configuration further down; Common Objects, Security Policies, QoS Policies, Management Services, Authentication, Keys and Certificates.

Authentication seems promising but I can't find anything about an API anywhere.

I've looked carefully but just can't spot it, sorry! Does what I describe match with what it looks like for you? If you could guide me through what to click, that would be really helpful and appreciated.

Thanks again.
Photo of Asad Rehman

Asad Rehman

  • 5 Posts
  • 2 Reply Likes
@Stephen
Here is a link for documentation of  HiveManager REST API.May be this will help you. http://www.aerohive.com/330000/docs/help/english/documentation/HiveManager_RESTful_API_Config_Guide_... In this documentation find Enabling Access to the HiveManager REST API Heading for help.
In addition i am writing steps to find enable option.
1- Click on Home
2- Then Find Administration from left menu and click it.
3- Then in administration sub-menu you will find HiveManager Settings.
4- After Clicking HiveManager Settings find  API Authorized Settings (Settings) in HiveManager Settings page.
5- Enable API Access: (select)
6- API Administrator: Enter the user name that you want your code to use when it queries the HiveManager REST API.
7-  And then click Save (disk icon).

I hope this will help you.
-------------For more details please read full documentation by clicking link below------------
http://www.aerohive.com/330000/docs/help/english/6.1r5/hm/full/Content/ref/doc.htm

Thanks.
Photo of Stephan Hughson

Stephan Hughson

  • 8 Posts
  • 2 Reply Likes
Thanks so much. I'm up and running now.
Feel a bit like I've put together some furniture without the instructions, got it wrong and been handed the manual with the right page open! I'll have a good read through that now.

Thanks again, case closed :-).
Photo of Asad Rehman

Asad Rehman

  • 5 Posts
  • 2 Reply Likes
You are welcome @Stephan and its good to here that it is working.
Good luck with HiveManager REST API :-)