Totally stand-alone AP running DHCP on wireless only?

  • 1
  • Question
  • Updated 5 years ago
  • Answered
Hi, I've got an AP350 that I'm trying to configure as simple stand-alone wireless device with a DHCP server. The device will have no WAN, bridged wireless, or wired LAN, unless configuring. I need to roll this device out to support a roving iPad demo cart that will travel to other sites.

I've tried configuring the device as a router, and that gets me my DHCP server, but any time you connect to the router as a wireless client and there isn't an active WAN connection the device pops up a page to clients asking to configure a WAN. On OS X I can just close the dialog and continue on my merry way, but on iOS if you cancel the dialog the connection drops.

I see where I can add a DHCP server when the device is in AP mode, but I don't want to hand out addresses over the ethernet ports (for those instances when I plug it in to modify config.)

I'm just a bit lost in general. Little help?
Photo of Greg Moore

Greg Moore

  • 16 Posts
  • 1 Reply Like

Posted 5 years ago

  • 1
Photo of Abby S

Abby S, Employee

  • 94 Posts
  • 47 Reply Likes
hi Greg,

You can turn off the feature that we use to check for WAN status in the Network Policy - Additional Settings - Service Settings - Track IP Groups for WAN. This feature normally makes sure there is Internet access so that a non-technical user doesn't get stranded without access when the device can't connect to HM. However, in your more technical use case, just turn it off and we'll stop prompting you for WAN connectivity :-)
Photo of Greg Moore

Greg Moore

  • 16 Posts
  • 1 Reply Like
AH! Excellent! I knew that had to be a setting somewhere.

Unfortunately, after clearing the the primary, backup 1 and backup 2 IP tracking items, pushing a full config, waiting for the reboot to finish, unplugging the AP and setting up without a WAN, it's still prompting.

So, I created a new IP tracking group with the "enable IP tracking" box UN-checked for the WAN interface. I had to put an IP into the "Track the following targets" field, despite having it unchecked, so I added Google's DNS server (8.8.8.8). Still no dice. I swapped the IP to check to 127.0.0.0. Still no go. I even disabled the webserver and I'm still, somehow, getting a WAN prompt when I connect. I'm pushing a full config every time. The device gets the new config, reboots, the indicator turns green, and after verifying the SSID is broadcasting I disconnect the network-side ethernet cable from the power injector (leaving the injected side powering the AP.) When I attempt to connect to the SSID, I still get the WAN prompt.

This is what my service settings are set to currently:



Any ideas for where I've messed up?
Photo of Greg Moore

Greg Moore

  • 16 Posts
  • 1 Reply Like
Well, after several hours of trying various permutations and changes, pushing the config over and over, rebooting, rebooting again, etc. I still hadn't managed to disable the WAN connection page. On a whim, I reverted the AP back to v5.1r5 and, lo and behold, it works perfectly with the blank IP tracking groups!

Not sure if it's a bug in v6.1r1.1247, or if reverting the firmware just reset something I had misconfigured. After the workshop I need this AP for I'll switch back to v6.1 and see if the problem reappears.
Photo of Abby S

Abby S, Employee

  • 94 Posts
  • 47 Reply Likes
Greg - wow! Thanks for trying that. We may have an unexpected behavior in 6.1.
Please let me know if the behavior changes when you upgrade and I'll make sure our engineering team tries it as well.