Toggle PoE on SR2024P Port or shut off port - seems impossible.

  • 1
  • Question
  • Updated 1 year ago
  • Answered
Good Morning
Been trying to toggle the PoE to a downstream AP on a SR2024P and despite fiddling around a lot, this does not seem to be a 'feature' or an option.

Additionally , may have found a bug which seems to suggest that when a port is setadministratively down on the Hivemanager , it is still live in the real world.

Proof.

Set port to be administratively down on Hivemanager. Updated switch



Port still up and running after update and live . Confirmed on the connected equipment as well.

Toggling a PoE supply is a essential part of any wireless administration and it is rather concerning that there is no support for this on AH switches as far as I can see. Further, 'administratively down' is not really port shutdown apparently .

Feedback welcome and do let me know what I may be doing wrong.

thanks
Photo of Anjanesh Babu

Anjanesh Babu

  • 68 Posts
  • 7 Reply Likes

Posted 5 years ago

  • 1
Photo of sbx

sbx

  • 28 Posts
  • 0 Reply Likes
There is a way to disable PoE on the ports. Go the the policy configuration mask where you would configure the ports and their profile. There is an option of additional Port Settings and there you can disable and enable power per port Obviously this is a nogo for multiple switches with the same profile and it should be available in the device conifguration port section so you can do a policy override.
Photo of Anjanesh Babu

Anjanesh Babu

  • 68 Posts
  • 7 Reply Likes
hi there - many thanks for the suggestion but there is no option apparent in any of the configuration settings - ports or otherwise to disable PoE. There is a shutdown option yes but not for PoE. Would you mind providing more specific steps just so that I know I am not looking in the wrong place ?
Besides as you rightly mentioned - this is a shotgun approach rather than a toggle for quick fix .

Further, after a bit of experimentation, found that I can shutdown the ports administratively using cli

eg. " interface 1/23 shutdown"

shutdowns traffic to that port but the PoE is still live on that port !!

No option to manage PoE in CLI as well. Seems like the Aerohive product team have left this one out.

We run latest 6.1r2a on VHM and HiveOS 6.1r2.1359 on the Switch (latest as of writing) .

thanks
Photo of Brian Ambler

Brian Ambler

  • 245 Posts
  • 126 Reply Likes
Hi Anjanesh,

In 6.1r2, the only way I know of to toggle PoE on a specific switchport is by running the following commands from the CLI of the switch:

int eth1/x pse shutdown
no int eth1/x pse shutdown

This will bring PoE down, then back up, which should accomplish what you need.

Example:


Proteus#sho pse port-brief
Interface Status Priority Consumption(W) Profile Name
--------- ------ -------- -------------- ------------
eth1/1 disabled low 0.000 default-pse
eth1/2 disabled low 0.000 default-pse
eth1/3 disabled low 0.000 default-pse
eth1/4 Searching low 0.000 default-pse

Proteus#int eth1/4 pse shut

Proteus#sho pse port-brief
Interface Status Priority Consumption(W) Profile Name
--------- ------ -------- -------------- ------------
eth1/1 disabled low 0.000 default-pse
eth1/2 disabled low 0.000 default-pse
eth1/3 disabled low 0.000 default-pse
eth1/4 disabled low 0.000 default-pse

Proteus#no int eth1/4 pse shut

Proteus#sho pse port-brief
Interface Status Priority Consumption(W) Profile Name
--------- ------ -------- -------------- ------------
eth1/1 disabled low 0.000 default-pse
eth1/2 disabled low 0.000 default-pse
eth1/3 disabled low 0.000 default-pse
eth1/4 Searching low 0.000 default-pse


Regarding your comment about setting the Ethernet port's Admin State to down but still seeing it as up, I think I can explain that for you. When setting the Admin State of any Ethernet port to down from "Switch Ethernet Port Settings" on the [Device Name] > Modify page, please make sure you are checking the tick box to "Override settings in network policy" or your changes will not take effect.


By default, Ethernet admin states are managed through the Network Policy using Device Templates (with classifiers, if necessary). So if all 24 copper ports on the switch are set to be administratively up on the Device Template to which they are assigned, then making a change under "Switch Ethernet Port Settings" will be overridden by the Network Policy, which is, I think, what you saw. I tested this before writing this update and confirmed that without this option ticked the Ethernet port was not shutdown, but when ticking this option and then pushing out the change the Ethernet port was shutdown.

Hope this helps
Photo of Anjanesh Babu

Anjanesh Babu

  • 68 Posts
  • 7 Reply Likes
Hi Brian - thank you for this tip . I was looking for the commands with poe in them and closest found was ppoe.
And appreciate the pointer to override the network policy settings as well.
Will try both of this .
thank you once again
Photo of Quinn Brewer

Quinn Brewer

  • 1 Post
  • 0 Reply Likes
Did anyone check if the device nic is bad. I have several cameras which cause this error and it has always been a bad nic or nic going bad. Spanning Tree will disable the port due to it is flooding or power is our of normal range.
Photo of sbx

sbx

  • 28 Posts
  • 0 Reply Likes
Hi

Here are the screenshots for the policy settings:



And in the section "additional port settings" on the bottom right, where you can toggle the enable option:

Photo of Anjanesh Babu

Anjanesh Babu

  • 68 Posts
  • 7 Reply Likes
Hi sbx,
many thanks for the screenshots - that helps !
Yes , now it makes sense.That link is only enabled when no ports are selected on the switch though.
This could be a possible option - as long as I don't update all switches and toggle the policy back .

I would still think that a quick process to enable or disable the PoE to a port through perhaps 'Monitor' --> 'Utilities' tab would be extremely helpful . Though I can see this is not easy as it sounds looking at the nesting of the features within the policies.
Photo of Anjanesh Babu

Anjanesh Babu

  • 68 Posts
  • 7 Reply Likes
Yay for HiveOS 6.1r3 ! 

Unless I missed this on the last release it would seem  like this toggle option  has now been implemented  and is just in the right place as well.