SSID with non-english characters.

  • 1
  • Question
  • Updated 6 months ago
  • (Edited)
Believe or not, but I haven't yet had the opportunity to create an SSID with non-english characters, in this case with swedish "ÅÄÖ". Now's the time and it failed miserably. We are replacing a customers old Cisco WiFi at a school with AP130s (6.5r7) and HM-NG. Customer wanted to keep the old SSIDs which contains swedish "ä". This has been running for 8 years without any  trouble. I remember creating SSID around 1999 with standard ISO-Latin1 characters.
Creating SSID containing this letter "ä" in HM-NG seems to work, but when applying the policy, all hell breaks loose; lots of alarms, WiFi-interface stays down, IP address changes from static to DHCP... ...until I skip characters not in 7-bit ASCII.

Is this a fact that Aerohive doesn't even support ISO-Latin1/8859-1 characters as SSIDs? Can't find any documentation about it.
Photo of gunverth


  • 3 Posts
  • 0 Reply Likes

Posted 9 months ago

  • 1
Photo of Jonathan Hurtt

Jonathan Hurtt

  • 98 Posts
  • 48 Reply Likes
Have you tried with HiveOS 8.0r1 on the AP130? I believe that does support these types of characters. 
Photo of Rick Barragan

Rick Barragan

  • 12 Posts
  • 2 Reply Likes
gunverth, I would report this to support if you haven't already done so. I know that when we upgraded from HM6 to HMNG we experienced issues with our admin privileges after the conversion and one of the NG upgrades didn't like the license conversion from HM6. So maybe an upgrade will either fix the issue or break it, but I would escalate this to support since it was working before, so therefore I would argue that they need to make it work in NG.  Just some thoughts, good luck.
Photo of Dusty Wilson

Dusty Wilson

  • 1 Post
  • 0 Reply Likes
My AP is on 8.1r1 and it has some serious issues with non-ASCII Unicode characters in the SSID.  In my case, it's the ❄ (snowflake) character.  It works great for UniFi APs, but doesn't work at all in HiveOS 7.0r4 and has a serious problem in HiveOS 8.1r1.

With 8.1r1 and an SSID of "❄" (literally one character long) using WPA2 PSK...

... you get the following result:

What you see there is the ❄ snowflake, yes, but it's completely open.  No authentication at all.  If a client attempts to connect to that, it works just fine, sadly.  It should not work as they are not authenticated, but the AP seems to believe no authentication is required.  Same thing happens on Android (open network, no lock indicator in WiFi connections list).

Additionally, in several places I'm seeing the SSID being represented in broken ways, such as this:

Notice halfway down that image you see "SSID=❄" instead of the expected "SSID=❄".  I suspect this sort of thing is causing or helping something else cause the failed authentication settings for this specific SSID.

Auth works perfectly for the other, non-Unicode-character'd, SSIDs on this same AP with the same HiveOS version.

I wouldn't normally care about something as silly as a ❄ SSID, but this unit is supposed to be replacing a UniFi AP that was using exactly that SSID for a couple handfuls of IoT devices.  It's going to be a real PITA to go update the WiFi details on all of those devices.  This means the UniFi AP goes back up and the Aerohive comes down.