Social Login not reporting anything but Facebook logins

  • 1
  • Question
  • Updated 3 years ago
  • (Edited)
I'm fairly new to Aerohive (having migrated away from a Cisco on-premise solution), and also new to the Aerohive Social Login functionality. We have Social Login up and running, and can authenticate using Facebook and LinkedIn (not tried Google+ or Twitter yet), but when I browse the logins through the CWP portal (Monitor tab), I can only see people who used Facebook? If I look under 'Logs' > 'Authentication Log', I can see the logons with the Vendor ID 'LNKD'.

Update: Just confirmed that Twitter works okay.

Any ideas?
Photo of Tony

Tony

  • 7 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
Tony,
I'll ask my product management peer who watches over the Social Login functionality to review this thread and respond, but I vaguely recall him mentioning that terms of service issues with some of the social networks that allows us to use those credentials but not to retain them. That may be a partial explanation for what you're observing.
Photo of Tony

Tony

  • 7 Posts
  • 0 Reply Likes
Thanks Mike, Sounds like it could well be the issue.

Tony
Photo of Andrew Garcia

Andrew Garcia, Official Rep

  • 368 Posts
  • 120 Reply Likes
Yeah, I remember that LinkedIn was the most stringent about their data retention rules.
Photo of Andrew Garcia

Andrew Garcia, Official Rep

  • 368 Posts
  • 120 Reply Likes
FYI, this is spelled out in the Social Login help.
Photo of Tony

Tony

  • 7 Posts
  • 0 Reply Likes
Thanks Andrew (and Mike). Thats answered my question.
(Edited)