SNMP not working

  • 1
  • Question
  • Updated 4 years ago
  • Answered
  • (Edited)
Greetings,

I have followed this guide: https://community.aerohive.com/aerohive/topics/snmp_server_setup

And my SNMP requests still don't work. I've also added the SNMP server in the mgmt IP filters and traffic IP filters under "Security Policies".
HiveManager version: Enterprise 6.1r2b

Any help appreciated!

Thanks,
Niko
Photo of DeNikow .

DeNikow .

  • 3 Posts
  • 0 Reply Likes
  • sad

Posted 4 years ago

  • 1
Photo of Carsten Buchenau

Carsten Buchenau, Champ

  • 356 Posts
  • 117 Reply Likes
Hi Niko,

Can you give us a few more details on what exactly you are trying to do?

- Access the Hivemanager via SNMP? (currently not supported!)
- Access Access Points via SNMP?
- Send out SNMP traps from the Hivemanager?
- Send out SNMP traps from the Access Points?

carsten
Photo of DeNikow .

DeNikow .

  • 3 Posts
  • 0 Reply Likes
All of the above, well except for the first one in that case. I can't find a well documented guide on how to achieve successful SNMP GET-requests or receive traps. I'm currently monitoring all of the devices in our network using OpManager. Whenever I make an SNMP request, the request gets a timeout.
Photo of Carsten Buchenau

Carsten Buchenau, Champ

  • 356 Posts
  • 117 Reply Likes
For Access Points, you need to configure 2 things:

1. SNMP object under Management server settings

Go to your Network policy / additional settings / management server settings and choose or create an SNMP object:



Enter your SNMP server settings and the community string iv using V2c (or credentials if using V3). This will be the trap server as well as the one IP being allowed to connect via SNMP.

Don't forget the APPLY button!


If you need a whole subnet to have SNMP access, add another entry, and choose a subnet entry. Just "Operation: Get" would be enough then.

Again, don't forget to hit the APPLY button...


2. SNMP interface settings

You need to allow SNMP access on the interface you are coming from. 

Go to your Network policy / additional settings / Traffic filter settings. I usually configure SNMP for the relevant interface only, by selecting the following:



Create a new filter profile, e.g. "Allow-SNMP", and make sure you enable SNMP:



Save everything, upload the configuration to your access points, and give it a try...

carsten

Photo of DeNikow .

DeNikow .

  • 3 Posts
  • 0 Reply Likes
Trying to make an SNMP request doesn't work, however I can ping the device (AP):


Traffic filter settings:


SNMP Assignments:


Allowing SNMP:


Well there you go, still not getting any response. I've already pushed the configuration to the AP's and rebooted them.

Thanks,
Niko

Photo of Carsten Buchenau

Carsten Buchenau, Champ

  • 356 Posts
  • 117 Reply Likes
Hi Niko,

So your community name is sno-pub, correct? And sorry to ask - but you are sure there is no Firewall between OpManager server and the Access Points that might block UDP 161 and/or 162?

Also, try to disable "Traps over Capwap", not sure what implications this has.

If this is still not working, you probably want to open a support ticket...

carsten