SNMP on Aero Hive AP managed via cloud

  • 1
  • Question
  • Updated 3 years ago
I have following configuration on the access points after pushing snmp configuration given by aero hive guid,

interface eth0 manage snmp
interface eth1 manage snmp
no snmp trap-info over-capwap
snmp trap-info over-snmp
no snmp reader version any community hivecommunity
snmp reader version v2c community aerohive

I am using nagios as my monitoring services.

Nagios can ping but can't do SNMP polling .. I have set up on host name for now.. but no luck.

any help will be appreciated.
Photo of nilay vyas

nilay vyas

  • 6 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Roberto Casula

Roberto Casula, Champ

  • 231 Posts
  • 111 Reply Likes
To allow SNMP GET, you need to:

1. Enable SNMP in the Traffic Filter options in your policy's Additional Settings
2. Configure an SNMP object for the Nagios server and specify type of GET+TRAP or GET (depending on whether you want Nagios to receive traps too), specify the SNMP version and community

From your partial configuration above, this looks fine (assuming is the IP address of your Nagios server), but check that you also have the lines "hive <your hive name> manage snmp"

When you say Nagios can't do SNMP polling, what OID is Nagios requesting when it polls? You could use, for example, "." which will return the system description (model number and HiveOS version).
Photo of nilay vyas

nilay vyas

  • 6 Posts
  • 0 Reply Likes
so finally it is working.. thanks for your help Roberto.. I found from the tools team they were polling on v1 rather then version 2.. I have requested to update verion 2 and it worked..