Since VMware is not passing the native VLAN, how can you untag the managment traffic?

  • 1
  • Question
  • Updated 5 years ago
  • Answered
  • (Edited)
Hi, I am installed a Free Bonjour Gateway but the VM can not communicate with the HiveManager. My question is how to set up the VM with static IP, VLAN? interface eth0 eth1 mode? management vlan? Since VM ware is not passing the native VLAN, how can you untag the management traffice ?
Photo of jim Zhou

jim Zhou

  • 3 Posts
  • 1 Reply Like

Posted 5 years ago

  • 1
Photo of Emilio Maldonado

Emilio Maldonado

  • 37 Posts
  • 11 Reply Likes
Hi Jim,
To ensure your VM communicates with your HiveManager, you will need to open ports 80 TCP and 12222 UDP for the destination IP address of the Hive Manager hosting the Bonjour Gateway management, which is 198.46.53.222.
As per the VM configuration take a look at this video (minute 3:50 shows the ESXi configuration).
https://www.youtube.com/watch?v=Omp0V2...

In addition, make sure your vSwitch security setting is set into promiscuous mode (Accept option) in the ESxi configuration option. Let us know if this solves it.

Emilio
Photo of jim Zhou

jim Zhou

  • 3 Posts
  • 1 Reply Like
Hi Emilio,

You did not answer my question. I need to know
1. how to set up the VM with a static IP?
2. interface eth0 and eth1 mode?
3. management interface and vlan?
I watched this video several times and it doesn't work as it tells.

Jim
Photo of Scott M.

Scott M., Sr. Support Engineer

  • 104 Posts
  • 8 Reply Likes
Hello Jim,

The Bonjour VM must use DHCP. The Bonjour device will create a virtual interface for each VLAN, and each VLAN will receive its own IP from DHCP. This means there must be a DHCP server on each VLAN and each will need to have a range with an available IP to hand-out to the virtual interface on the Bonjour VM.

When you say "eth0 and eth1 mode?", I imagine you are referring to static vs. dynamic IP. Again, you should use DHCP for the entire device and all interfaces.
Photo of Scott M.

Scott M., Sr. Support Engineer

  • 104 Posts
  • 8 Reply Likes
Hello Jim,

I believe that Emilio answered a portion of your question. I hope I was able to address the other portion. Please let us know if we missed anything.
Photo of Tj

Tj

  • 1 Post
  • 0 Reply Likes
I had the same questions. the only way to set a static address on the management interface it to configure the mgt0 interface to a vlan that has dhcp. from command prompt:

int mgt0 vlan ###

once the vm connects to the manager you can then configure additional vlans and then configure the mgt0 interface with a static ip address.



Photo of jim Zhou

jim Zhou

  • 3 Posts
  • 1 Reply Like
Hi Scott,

When I consoled in the VM and "show running-config", there are interface mode settings.
interface eth0 mode wan
interface etho mode bridge-802.1q
interface mgt0 vlan 302

what are the recommended settings?

thank you,

Jim
Photo of mixtape

mixtape

  • 2 Posts
  • 1 Reply Like
Hi, Jim.

This how I could change the management vlan id in the VM from the CLI.

in the cli do the following:
1)Erase the IP address from eth0
no int eth0 ip
2)Change the eth0 interface mode to backhaul
int eth0 mode backhaul
3)configure the mgt0 interface vlan and ip address
int mgt0 vlan "vlanid"
int mgt0 ip "ip_address" "netmask"
4)configure the default gateway
ip route default gateway "ip_address"

Hope it helps.

Mixtape.