radius authentication

  • 1
  • Question
  • Updated 5 years ago
  • Answered
Friends of Aerohive,

I'm having trouble with radius authentication.

Some machines Macos and Windows 8, can no longer authenticate, in fact, not even the login screen for user input and password appears, the communication is terminated before that.

Seems to me a problem in the first phase of authentication.

I appreciate the help.

Regards,

Pedro Nakano
Photo of Pedro Nakano

Pedro Nakano

  • 7 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Gary Smith

Gary Smith, Official Rep

  • 299 Posts
  • 61 Reply Likes
Hi Pedro,

Can you give some more details on the configuration you are using?
Can you also capture the client monitor output at the time of the authentication attempt?

Kind Regards,
Gary Smith
Photo of Pedro Nakano

Pedro Nakano

  • 7 Posts
  • 0 Reply Likes
Gary,

logs in my macbook.

Oct 2 10:09:32 MacBook-Nakano Apple80211 framework[675]: airportd MIG failed (Associate Event) = -3900 (Parameter error) (port = 27515)
Oct 2 10:09:32 MacBook-Nakano System Preferences[675]: Error joining MRE_UserSERE: A conexão falhou (-3900 result unavailable)
Oct 2 10:09:32 MacBook-Nakano airportd[760]: Apple80211Associate() failed -3900 (Parameter error)
Oct 2 10:09:32 MacBook-Nakano Apple80211 framework[675]: airportd MIG failed (Associate Event) = -3900 (Parameter error) (port = 27515)
Oct 2 10:09:32 MacBook-Nakano System Preferences[675]: Error joining MRE_UserSERE: A conexão falhou (-3900 result unavailable)

regards.
Photo of Gary Smith

Gary Smith, Official Rep

  • 299 Posts
  • 61 Reply Likes
Hi Pedro,

It is still not clear what security you are using on your SSID and at what stage the authentication is failing. Are you able to give this detail? The client monitor tool output would be a useful starting point.

Kind Regards,
Gary Smith
Photo of Pedro Nakano

Pedro Nakano

  • 7 Posts
  • 0 Reply Likes
Gary,

I'm using Radius on Windows Server 2012.

And the problem is happening before arriving at Radius.

It is as if the AP does not accept the connection.

Best Regards,

Pedro Nakano
Photo of Andrew MacTaggart

Andrew MacTaggart, Champ

  • 483 Posts
  • 86 Reply Likes
You have to be specific about your setup

SSID should have a radius profile
are you using 802.1x
wpa2/enterprise?

the radius servers need to be created in the hive and the shared secrets must match from the authenticator [the AP] to the authentication server [The Radius Server]

The supplicants [the clients] must use supported eap protocol that must be supported on the authentication server.

check out David's blog for trouble shooting tips.

http://blogs.aerohive.com/blog/the-wi...