Problem to authenticate on Social Login - "500 ERROR ACPP Configuration is wrong"

  • 1
  • Question
  • Updated 1 year ago
Hi everybody,

I did enable the social login service, but when I try to access the Guest SSID I cant authenticate. On my browser show the message: "500 ERROR ACPP Configuration is wrong". I did open TCP 80, and 443 ports on my firewall, like show at AeroHive Oficial document. I dont know whats metter with this issue. Is there anybody here with the same problem? 
Please, I need help to solve this issue.
Thanks very mutch.

regards,
Photo of Matheus Ferreira Cota

Matheus Ferreira Cota

  • 1 Post
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Sam Lynn

Sam Lynn, Moderator

  • 96 Posts
  • 12 Reply Likes
Hello,

Your HiveManager is likely setup for beta services and with that it is pushing out a configuration to change the root URL to 'accp-beta.aerohive.com': 

security-object ActiveView-Social security additional-auth-method captive-web-portal cloud-cwp url-root-path https://acpp-beta.aerohive.com 

Removing the beta services from HiveManager will remove this line of configuration, which is causing the issue you're having. I would recommend disabling the Beta Services in the Home Tab> Administration> HiveManager Settings> Beta Services.

Alternatively, if you wish to keep that enabled, you can run the following command manually through the CLI of the AP to remove that command: 

no security-object ActiveView-Social security additional-auth-method captive-web-portal cloud-cwp url-root-path 

If you do want to keep the Beta Services enabled, you need to run this command every time you push a configuration to the AP. In that case, we would want to create a supplemental CLI object to automate this for you.

Hope this helps!