Polycom Spectralink 8400 wireless phone

  • 1
  • Question
  • Updated 5 years ago
  • Answered
Anyone have any success on getting one of these IP phones to connect? We are trying to get one connected on a WPA2-PSK SSID with nothing special on the config. We have WMM enabled like the manual says but it just won't connect. Thoughts? We are trying to get away from the "Bridge Company" since they don't support WPA2 and we are trying to get rid of WEP...

Andy
Photo of Andy Cannarella

Andy Cannarella

  • 31 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
If you use the Client Monitor to "watch" the Spectralink 8400 associating to the wireless network what do you see?
Photo of Andy Cannarella

Andy Cannarella

  • 31 Posts
  • 0 Reply Likes
Not yet, I am not fully involved with it yet, posting for a coworker. I was going to see if I was going to fight an up hill battle... I was just wondering if someone got one working at all. I will check the logs on the APs that service it.
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
I have got Cisco and Ascom phones working and I found that 90% of authentication issues were caused by incorrect configurations on the phones.

Looking at the Client Monitor logs will show if the issue is the passphrase.
Photo of Andy Cannarella

Andy Cannarella

  • 31 Posts
  • 0 Reply Likes
What model Cisco? Is it doing WEP or WPA?
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
Cisco 7925 utilising WPA2
Photo of Andy Cannarella

Andy Cannarella

  • 31 Posts
  • 0 Reply Likes
Really, my 7921 and 7925 don't offer WPA2. Just LEAP, EAP, PEAP and Auto besides Open and WEP. What code version?
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
The 7925 supports WPA2 but Cisco hides that information away.

Authentication:

• Cisco Wireless Security Suite IEEE 802.1X
• Lightweight Extensible Authentication Protocol (LEAP) Authentication
• Protected Extensible Authentication Protocol (PEAP) MS-CHAP Version 2
• Extensible Authentication Protocol and Flexible Authentication with Secure Tunneling (EAP-FAST)
• Extensible Authentication Protocol and Transport Layer Security (EAP-TLS)
• Wi-Fi Protected Access (WPA) Versions 1 and 2: Personal and Enterprise
• Cisco Centralized Key Management (CKM)

Encryption:

• 40- and 128-bit static Wired Equivalent Privacy (WEP)
• Temporal Key Integrity Protocol (TKIP) and Message Integrity Check (MIC)
• Advanced Encryption Standard (AES)

Source: http://www.cisco.com/en/US/prod/colla...

Set the authentication mode to Auto (http://www.cisco.com/en/US/docs/voice...).
Photo of Andrew Garcia

Andrew Garcia, Official Rep

  • 368 Posts
  • 120 Reply Likes
I've never used the 8400 specifically, but I have used the 8030 in the past. For the 8030, you need to turn on UAPSD support on the SSID.

In your SSID setup, under Optional Settings, expand Advanced.
Check Enable Unscheduled Automatic Power Save Delivery.

Save your SSID, and push to your APs.

I'll look into whether there are more steps for the 8400, in the mean time.
Photo of Andrew Garcia

Andrew Garcia, Official Rep

  • 368 Posts
  • 120 Reply Likes
I read a tech note that says you have to disable support for WMM-AC on the phone, as well as enable UAPSD (and the SIP ALG, for improved voice quality).

To toggle the "AC Required" option on the phone itself, go to Settings > Advanced Settings > Administration Settings > Network Configuration > Network Interfaces > Wi-Fi Menu > AC Required: Yes/No.

To toggle this setting in the config files, open the master config file and under device.wifi, you will find 2 options: "device.wifi.acMandatory" "device.wifi.acMandatory.set" Set the first option to "0" and the second to "1"."

Or, as an alternative, Aerohive just added support for WMM-AC (for the AP330/350/121/141) in 6.0r2, which was released a few days ago.
Photo of Andy Cannarella

Andy Cannarella

  • 31 Posts
  • 0 Reply Likes
Ok so adding the UAPSD worked. Weird. the WMM-AC was already off on the phone. I got an IP address. Thanks.