Not able to connect thermostat to wifi, status code 18?

  • 1
  • Question
  • Updated 1 year ago
I want to connect a thermostaat to a WPA2 Network, but it doesn't connect to the WiFi network. I did a client monitor on MAC address and i see it authenticating, or at least it tries. Below a snippet from the log. Status code means something with the transfer rates. But i can't seem to find anything.

-2017 04:15:55 PM  0060341402A8  D854A204F118  AP503        BASIC   (69)Rx auth <open> (frame 1, rssi -41dB)
09-02-2017 04:15:55 PM  0060341402A8  D854A204F118  AP503        BASIC   (70)Tx auth <open> (frame 2, status 0, pwr 13dBm)
09-02-2017 04:15:55 PM  0060341402A8  D854A204F118  AP503        BASIC   (71)Rx assoc req (rssi -35dB)
09-02-2017 04:15:55 PM  0060341402A8  D854A204F118  AP503        BASIC   (72)Tx assoc resp <reject> (status 18, pwr 13dBm)
09-02-2017 04:15:55 PM  0060341402A8  D854A204F116  AP503        BASIC   (73)Sta(at if=wifi0.3) is de-authenticated because of notification of driver
09-02-2017 04:15:55 PM  0060341402A8  D854A2EA3398  AP504        DETAIL  (33)Rx <specific> probe req (rssi -56dB)
09-02-2017 04:15:55 PM  0060341402A8  D854A2EA3398  AP504        BASIC   (34)Tx probe resp (pwr 13dBm)
09-02-2017 04:15:55 PM  0060341402A8  D854A2EA3394  AP504        BASIC   (35)Tx probe resp (pwr 13dBm)
09-02-2017 04:15:55 PM  0060341402A8  D854A2EA3398  AP504        DETAIL  (36)Rx <specific> probe req (rssi -52dB)
09-02-2017 04:15:55 PM  0060341402A8  D854A2EA3398  AP504        BASIC   (37)Tx probe resp (pwr 13dBm)
09-02-2017 04:15:55 PM  0060341402A8  D854A2EA3394  AP504        BASIC   (38)Tx probe resp (pwr 13dBm)
09-02-2017 04:15:55 PM  0060341402A8  D854A2EA3398  AP504        DETAIL  (39)Rx <specific> probe req (rssi -61dB)
09-02-2017 04:15:55 PM  0060341402A8  D854A2EA3398  AP504        BASIC   (40)Tx probe resp (pwr 13dBm)
09-02-2017 04:15:55 PM  0060341402A8  D854A2EA3394  AP504        BASIC   (41)Tx probe resp (pwr 13dBm)
09-02-2017 04:15:56 PM  0060341402A8  D854A204F118  AP503        BASIC   (74)Rx assoc req (rssi -37dB)
09-02-2017 04:15:56 PM  0060341402A8  D854A204F118  AP503        BASIC   (75)Tx assoc resp <reject> (status 18, pwr 13dBm)
09-02-2017 04:15:57 PM  0060341402A8  D854A204F118  AP503        BASIC   (76)Rx assoc req (rssi -35dB)
09-02-2017 04:15:57 PM  0060341402A8  D854A204F118  AP503        BASIC   (77)Tx assoc resp <reject> (status 18, pwr 13dBm)
09-02-2017 04:15:58 PM  0060341402A8  D854A204F118  AP503        BASIC   (78)Rx assoc req (rssi -35dB)
09-02-2017 04:15:58 PM  0060341402A8  D854A204F118  AP503        BASIC   (79)Tx assoc resp <reject> (status 18, pwr 13dBm)
09-02-2017 04:15:59 PM  0060341402A8  D854A204F118  AP503        BASIC   (80)Rx assoc req (rssi -35dB)
09-02-2017 04:15:59 PM  0060341402A8  D854A204F118  AP503        BASIC   (81)Tx assoc resp <reject> (status 18, pwr 13dBm)
09-02-2017 04:16:00 PM  0060341402A8  D854A204F118  AP503        INFO    (82)Rx deauth (reason 1 <unspecified>, rssi -41dB)
09-02-2017 04:16:00 PM  0060341402A8  D854A204F118  AP503        BASIC   (83)Sta(at if=wifi0.5) is de-authenticated because of notification of driver
09-02-2017 04:28:24 PM  0060341402A8  D854A2EA3396  AP504        DETAIL  (42)Rx <broadcast> probe req (rssi -52dB)
09-02-2017 04:28:24 PM  0060341402A8  D854A2EA3396  AP504        BASIC   (43)Tx probe resp (pwr 13dBm)

Any ideas how to solve this?
Photo of Sebastiaan Bosveld

Sebastiaan Bosveld

  • 32 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Joel Brooks

Joel Brooks

  • 20 Posts
  • 4 Reply Likes
Sounds like you need to adjust your basic radio rate in your radio profile.
Photo of Sebastiaan Bosveld

Sebastiaan Bosveld

  • 32 Posts
  • 0 Reply Likes
Hi Joel, Thanks for your reply. Any idea what i should be looking for?
Photo of Joel Brooks

Joel Brooks

  • 20 Posts
  • 4 Reply Likes
Have you modified your default radio profiles?
Photo of Sebastiaan Bosveld

Sebastiaan Bosveld

  • 32 Posts
  • 0 Reply Likes
The rates aren't in my radio profile but in the properties of the SSID. I have created own radio profiles and left the default ones intact just in case.
Photo of Joel Brooks

Joel Brooks

  • 20 Posts
  • 4 Reply Likes
My mistake sorry, I was not sitting at the console. Not sure then. Something is blocking the tx but I don't know what. It may be requesting a rate below the settings you have specified? For instance, we disallow anything below 24mbps on 2.4 and 5.