Moving around the office without dropping connection

  • 1
  • Question
  • Updated 5 years ago
  • Answered
I am just setting up an office, and did some network analyzer testing, everything looks great! The problem is, as I am moving around the office with my computer or any other device, I drop when going from one AP to another. I know it should be doing this, or if so should be a very fast transition (I drop for about 10 seconds while it re-authenticates). Any ideas on why this is happening, or how to fix it?

Thanks
Photo of Aaron LeMoine

Aaron LeMoine

  • 2 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
I assume you mean for WPA2-Enterprise / 802.1X?

If so, you can watch the air for the EAPOL exchange and RADIUS and DHCP traffic on the wire with Wireshark to determine where things are getting caught up when things are slow.

Also, for the best speeds, look at the fast roaming techniques here and check things are set up correctly on both the AP and client:

http://revolutionwifi.blogspot.co.uk/2012/02/wi-fi-roaming-analysis-part-2-roaming.html

Nick
Photo of Andrew MacTaggart

Andrew MacTaggart, Champ

  • 483 Posts
  • 86 Reply Likes
As Nick Says he has to assume

So many factors are involved with roaming

is the office on one floor
are APs all in one mgmt vlan
Is there one vlan for users or multiple vlans
What is the authentication mechanism being used
where are the radius and dhcp servers located
Clients make the roaming decision, completely proprietary
Do you have cell overlap of 15 to 20%, not that you can measure what 15 to 20 % is.

determine if you are doing L2 or L3 roam, or if you have FT setup

you should check out Devin Akin's blog as well

http://blogs.aerohive.com/blog/wi-fi-...

http://blogs.aerohive.com/blog/wi-fi-...

http://blogs.aerohive.com/blog/wi-fi-...

http://blogs.aerohive.com/blog/wi-fi-...

CWSP® Certified Wireless Security Professional Official: Study Guide
Chapter 7 has excellent information about roaming
by
David D. Coleman,
David A. Westcott,
Bryan E. Harkins,
Shawn M. Jackman

Cheers
A
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
A commonly overlooked possible cause of what you are describing is too high transmit powers on the access points causing the cell overlap to be too high.

A wireless clients decides it wants to roam when one of more vendor specific conditions are triggered. These conditions could include the RSSI (perceived signal strength) dropping below a certain level, the SNR (difference between the perceived signal strength and the perceived noise level) drops below a certain level, the retry rate increases past a specific level, or a combination of the above. If the cell overlap is too high then the vendor specific condition(s) are not triggered in optimal locations and wireless performance is adversely affected. If the wireless client does not initiate a roam before it has to then you can experience disassociations as you describe.

This issue can be compounded by having a 802.11b or low 802.11g data rate configured as mandatory/basic. This is because this data rate could be utilised for beacon transmission resulting in the wireless clients being reluctant to roam.
Photo of Aaron LeMoine

Aaron LeMoine

  • 2 Posts
  • 0 Reply Likes
Crowdie, you are the big winner. After calling Aerohive last night, they pointed out just that. The AP's had lowered the power down as much as they could. We adjusted the max, and several lowered the power down still.

Once we made the adjustments, as well as took our old AP system offline, everything has been running much better. Little to no drops have been seen since.

Thanks everyone for your replies, I greatly appreciate it.
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
For people who are not aware the Aerohive Channel Selection Protocol (ACSP) will not drop the transmit power of a radio below the maximum value assigned in the radio profile less 6 dBm. So, if the transmit power maximum is set to 20 dBm the ACSP will not drop the transmit power below 14 dBm, which can commonly be too high - especially for multi-floor premises.
Photo of Andrew MacTaggart

Andrew MacTaggart, Champ

  • 483 Posts
  • 86 Reply Likes
Thanks Crowdie

I saw this when I had the radios set to auto power, the APs would either select 20dBm or 14 dBm.

It is good to know why.

Where did you find that tidbit of knowledge?

so you would adjust the max transmit power in the radio profile and then - 6 dBm for the lowest dynamic value



Help says

Max Transmit Power: Use this option on radio profiles for which you intend to apply automatic power selection (see "Aerohive AP Settings"). With this option, you set the maximum transmission power that the radio can use. By default, the maximum transmission power option is enabled. For the radio in 11b/g mode the default setting is 20 dBm. For the radio in 11a mode, it is 15 dBm. Aerohive has determined that these two settings provide optimal performance in the majority of cases when using automatic power selection. However, if there is more interference or contention than normal, you can reduce the area of radio coverage by setting a lower maximum power level and deploying the APs more densely. The range is from 10 to 20 dBm.

This option is particularly useful for the 11a mode radio because it can support up to 20 dBm, and yet the optimal maximum power level for 11a is 15 dBm. By enabling this option, the lower default setting of 15 dBm provides better performance. For the radio in 11b/g mode, the optimal maximum transmission level is the same as the maximum transmission level of the radio, so enabling this option with its default setting is not really necessary. On the other hand, it is still useful for the 11b/g radio in special cases when you need to reduce the amount of coverage to reduce contention and interference.
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
> Where did you find that tidbit of knowledge?

I was deploying a VoIP wireless network at a hospital and noticed that the Aerohive wireless network was considerably "hotter" than the Cisco equivalents and we were getting sticky clients. I raised a case with Aerohive Support and asked a few questions about radio management and that's when I found out about the 6 dBm difference.

> For the radio in 11b/g mode the default setting is 20 dBm. For the
> radio in 11a mode, it is 15 dBm

This is wrong and doesn't make sense. A 2.4 GHz signal has lower attenuation than a 5 GHz signal so why would you have the 2.4 GHz transmit power 5 dBm higher than the 5 GHz transmit power?
Photo of Loren

Loren

  • 48 Posts
  • 2 Reply Likes
Hey guys

What would you suggest setting the max Transmit Power to? Right now I am running 1 AP per two classrooms and moving towards a 1:1 where I have a higher density of clients.

thanks
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
For educational 1:1 deployments involving iPads I tend to set the 2.4 GHz max transmit power to 15 dBm. The 5 GHz max transmit power can be harder to set as the 5 GHz signal is more likely to be adversely affected by thick walls, metals, etc.