Modifying CAPWAP delay time threshold

  • 7
  • Question
  • Updated 4 years ago
  • Answered
I usually get the "Major" alert due to delay time of around 190 ms between my APs and HMOL. It's probably due to geographical location as my Singapore APs are connected to US HMOL. Is there anyway of increasing the threashold value to around say... 250-300ms?

Regards
Kevin
Photo of Kevin Chen

Kevin Chen

  • 4 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 7
Photo of Mathew Edwards

Mathew Edwards, Employee

  • 15 Posts
  • 16 Reply Likes
Hi Kevin,

If you raise a support case with your supplier, our support desk will be able to move your account to our singapore server which should solve your delay problem.

You will need to provide your VHM-ID which can be found by logging into your HiveManager and top right corner selecting - help - about HiveManager.

Thanks
Mathew
Photo of Scott M.

Scott M., Sr. Support Engineer

  • 104 Posts
  • 8 Reply Likes
Hello Kevin,

I was told that practically speaking, there is no way to increase the CAPWAP threshold.
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
A little off topic but we found with our 5.1r1 and 5.1r3 deployments using an on-premise HiveManager that we continuously got "CAPWAP Timeout" alerts even though the access points were remaining connected to the HiveManager. We increased the CAPWAP timeouts as high as we could in the HiveManager but this didn't resolve the issue.

We also found that when we logged into HiveManager we kept getting the following warning - "License information will automatically be removed because HiveManager lost its network connection with the license server (hmupdates.aerohive.com). Please check your network settings."

Upgrading the on-premise HiveManagers to 5.1r5 appears to have resolved both issues.
Photo of Mohanantass

Mohanantass

  • 45 Posts
  • 0 Reply Likes
hi team,

do we have any settings where I can change the CAPWAP threshold ? if yes please assist me. I have the same problem. using HMOL and always have this "major" alert and customer is worried when see major.

Regards,
Mohan
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
I don't believe you can change the CAPWAP timeout on an HMOL solution but I could be wrong. In the on-premise HiveManager the CAPWAP timeout settings are configured at Home -> Administration -> HiveManager Services -> Update CAPWAP Server Settings.

In the HMOL, however, you can change the E-mail alerts at Home -> Administration -> HiveManager Services -> Update Email Service Settings.

Photo of Mohanantass

Mohanantass

  • 45 Posts
  • 0 Reply Likes
Hi Crowdie,

I have don't this settings on the email alert but customer is monitoring the AP's using the Hivemanager, so when the alert shows as Major they call me and asking on how this can increased so that it all looks green and nice.

Regards,
Mohan
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
Are the customer's APs losing connectivity with the HMOL for any reasonable period of time?
Photo of Mohanantass

Mohanantass

  • 45 Posts
  • 0 Reply Likes
No the Ap is not losing connectivity, its just that the customer is unhappy to see a alert saying "major" in the monitor screen of the hivemanager.
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
I SSH'd into an access point connected to a HMOL and the standard CAPWAP timeout settings were not present. The only CAPWAP configuration I could find was to point the access point to the VHM:


capwap client server name xxxxxxxxxxxxxxxxxxxxxxxx
capwap client dtls hm-defined-passphrase *** key-id 1
capwap client vhm-name xxxxxxxxxxxxxxxxxxxxxxxx
no capwap client dtls negotiation enable


Therefore, I suspect that HMOLs do not support the changing of CAPWAP timeouts.
Photo of Bradley Chambers

Bradley Chambers, Champ

  • 302 Posts
  • 53 Reply Likes
I'd like to see this options as well. I have cleared major errors all the time.
Photo of Scott M.

Scott M., Sr. Support Engineer

  • 104 Posts
  • 8 Reply Likes
Assuming a feature such as the one suggested were introduced to modify the CAPWAP threshold, it would need to be a per AP or per VHM configuration option rather than per server.

There's probably a reason this option is not already available. I'll see if I can find out.
Photo of Scott M.

Scott M., Sr. Support Engineer

  • 104 Posts
  • 8 Reply Likes
Hello Kevin,

Mathew is correct. We should look at your VHM and see whether it is located on the most efficient server located closest to your location.
Photo of Mohanantass

Mohanantass

  • 45 Posts
  • 0 Reply Likes
hi Team,

So, can I say that the option to change the threshold is not an option and its fixed ?
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
Mohanantass, Yes, that is correct. No option to change that in current product. I and my peers do monitor this forum and take feedback such as in this thread into consideration for future improvements to our products, but I cannot comment right now on if or when you will see this change.
Photo of Scott M.

Scott M., Sr. Support Engineer

  • 104 Posts
  • 8 Reply Likes
Hello Kevin,

I think I found you in our system. Appears that your VHM is located on a server located to service the west-coast of the United States, but you are in Singapore. We have other servers closer to your location. You have the option to have your server moved to Australia or Amsterdam. Seems there's a good chance this might reduce latency, which could address the root cause of the issue.
Photo of Mohanantass

Mohanantass

  • 45 Posts
  • 0 Reply Likes
Hi Mike,

Thank you for your information.

Mohan
Photo of Ruby

Ruby

  • 1 Post
  • 0 Reply Likes
I'd like to see this option as well. Some AP's are on a satellite link and are giving major alarms all the time.
Photo of Weimin Du

Weimin Du

  • 4 Posts
  • 0 Reply Likes
The feature is to monitor CAPWAP delay between APs and HM server.
The purpose is to inform customers when HM/AP connection is not capable of management operations (e.g., image upload).
If some of devices constantly above the threshold, it is probably time to fix slow connection.
For example, move to a closer server as Scott has suggested.

Reading the thread, the concern seems mainly on alarms.
Do you also find it disturbing to see CAPWAP connection icon in orange?
One possible improvement is to add a control to allow customers to disable alarms, but keep connection status color.
Photo of Denis Paiva

Denis Paiva

  • 2 Posts
  • 0 Reply Likes
Configuration > Hives > Select your hive config
Photo of Margrethe Decena

Margrethe Decena

  • 3 Posts
  • 0 Reply Likes
Hi, I am also getting the same error. My VHM is VHM-GC188Q. Help?

Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
Margrethe, everyone else,
As of HiveManager 6.1r3 there is still no way for you to adjust the CAPWAP timers on an individual AP basis. We ARE looking at improving this, based largely on the feedback we have received in this forum. What we are considering for a future release is to
  • provide ways to configure the delay threshold for CAPWAP alarms
  • provide a means to control the triggering of CAPWAP alarms based on link latency
  • make CAPWAP alarms more meaningful and useful.
I cannot comment in any more detail or with particular timing, but please be assured that we are looking to improve this area in a future release.

Photo of Jeremy Stewart

Jeremy Stewart

  • 47 Posts
  • 0 Reply Likes
I had the same issue with CAPWAP notifications.... in Canada! It's been a known issue for some time, and the only solution has been documented to disregard it. You cannot change the threshold value in HMOL. I made this a huge issue being a paid subscriber, and not being able to effectively get notifications. They've promised an HMOL release this year that actually resolves the matter, instead of ignoring it.
Photo of Eddy

Eddy

  • 9 Posts
  • 0 Reply Likes
I have suddenly started having this issue.  "The current capwap delay time lower than threshold value." Twelve of our APs are sending me email alerts about this on a nearly minute by minute basis --ten alerts in ten minutes.  When I opened my email this morning --well, you can imagine the flood I received. How do I "fix" or "take control" of this?

Photo of Weimin Du

Weimin Du

  • 4 Posts
  • 0 Reply Likes
A quick work-around is to disable CAPWAP email notification (under HiveManager Services).
Photo of Eddy

Eddy

  • 9 Posts
  • 0 Reply Likes
Thank you.  That stopped the flood. Is there other action I should take?  Is there an issue I should be looking in to?
Photo of Weimin Du

Weimin Du

  • 4 Posts
  • 0 Reply Likes
Probably want to check and see why CAPWAP connection becomes slow. Otherwise, some of management operation, esp config update, may fail.