Mobile device connection problem

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Hello,

We ran into a problem with connecting mobile devices. The mobile devices will only connect wen we choose for WEP Encryption. Anything higher won't work. They will get an connection error (android) or password error IOS. The password entered is 100% correct. Laptops don't have this problem.

The units are the AP230 with software version HiveOS 6.2r1a.1931. Managed through HiveManager online.

Is this a known problem or is there a configuration that we are missing?

Greetings
Tom
Photo of Customer Support ICTZ

Customer Support ICTZ

  • 3 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
Can you check that you have not disabled WMM by accident?
Photo of Customer Support ICTZ

Customer Support ICTZ

  • 3 Posts
  • 0 Reply Likes
WMM is not enabled. I will turn it on an try again
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
Out of interest, do you know how this managed to become disabled?

I am going to raise a request to adjust the text in HiveManager to make it clear that disabling WMM is nearly always a mistake and a bad thing. By spec, it limits clients to 802.11g data rates (so no 802.11n or 802.11ac rates) and causes significant compatibility issues.
(Edited)
Photo of Customer Support ICTZ

Customer Support ICTZ

  • 3 Posts
  • 0 Reply Likes
We have a Public and a Private network setup. Public only open for internet. Private for everything. The Private has WMM enabled and Public had i disabled. I don't know the reason why it was disabled. I will need to ask the person that did the configuration. 
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
Cool, thanks.

Apple publish the following guidance, for reference:

http://support.apple.com/en-gb/TS3727
(Edited)
Photo of Hivefan

Hivefan

  • 23 Posts
  • 4 Reply Likes
Hi Nick,

Thank you so much for sharing the Apple article about WMM. I also see this description in HiveManager Online help. Let us know if there is some way we can make it clear. 

Enable WMM: By default, Aerohive devices support WMM® (Wi-Fi MultimediaTM) traffic prioritization and advertise such support in the beacons they transmit. Leave the check box selected to enable support of WMM-marked frames for traffic categorization and QoS (Quality of Service) purposes.

In addition to using WMM for QoS, 802.11n HT (High Throughput) aggregation mechanisms such as block acknowledgments (block ACKs) rely on the WMM Traffic Identifier (TID) subfield in frame headers to function. To provide HT for 802.11n wireless clients, keep the check box selected. Otherwise, the maximum link rate for all clients, including those that support 802.11n, will be 54 Mbps.

Regarding your suggestion about adjusting the text in HiveManager, are you talking about text in this screen? 
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
Hi Fan,

Yes, I was specifically referring to the text within HiveManager itself, nothing to do with the help documentation. I think that it would be a great thing to make it abundantly clear there that disabling WMM is very likely to be a mistake in an upfront way.

There is a lot of bad advice on the Web suggesting to disable it that makes this configuration fault prevalent.

The same issue occurred here: https://community.aerohive.com/aerohive/topics/very-low-data-rates-on-os-x

I think it makes sense to highlight this in a more discoverable and visible way.

Nick
(Edited)
Photo of Hivefan

Hivefan

  • 23 Posts
  • 4 Reply Likes
Thanks Nick! I followed the link you provided and read the article. I agree with you that HiveManager UI should provide clearer warning message about the impact of turning off WMM.  I will bring this input to my product management teammate and engineering. You could respond to this thread to get update from me in case you don't hear me soon in the new year. Thanks again. 

Fan