Issue creating and editing a new CaptiveWebPortal in HiveManager Connect

  • 1
  • Question
  • Updated 1 year ago
Hi folks,

I've some troubles with creating and editing a new CaptiveWebPortal in HiveManager Connect.

The situation is as followes:

1) I create a new CaptiveWebPortal named "Test"
2) I enable "User Auth on Captive Web Portal"
3) I add the link to the login page
4) As password encryption I choose "UAM Basic"
5) I save the new portal with success

Further:

1) I edit the CaptiveWebPortal created before
2) "Enable UPA" is active again
3) Cannot change to "User Auth on Captive Web Portal" again

What means that the settings are not saved correctly and also it's disabled to change it. But if I create and edit the portal through an Guest-SSID I can do all this changes.

Now I have two questions on this:
1) Does anybody know something about this behavior?
2) In the section "Login page" what is the password encryption for? Is this the algorithm the password is forwarded to the Radius server?

Thanks for your assistance in advace.

Best regards,
Bernd
Photo of Bernd Heissenberger

Bernd Heissenberger

  • 19 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Sam Lynn

Sam Lynn, Moderator

  • 96 Posts
  • 12 Reply Likes
Hello,

There is no scenario where you should be able to use a Captive Web Portal (CWP) that is both a User Auth and a UPA. This is a built in exclusion as we do not support CWPs that do both at the same time.

Furthermore, the Guest SSID (set up through the expedited Guest SSID creation process) should only be showing you a UPA CWP option. 

Could you show screen shots of your being able to do this set up on your Guest-SSID?
Photo of Bernd Heissenberger

Bernd Heissenberger

  • 19 Posts
  • 0 Reply Likes
Hi Sam,

you're absolutely right, it's not possible to create a CWP other than one with UPA through the wizard for a Guest-SSID. But I'm able to create a "normal" SSID and add them a configuration for using a CWP.

Ahhh, ... maybe that was a little bit confusing from my explanation. I did not create my Guest-SSID through the wizard. So, that means that all my explanations refer to a manual created SSID with a CWP.

So, I will give you a few screenshots about what I'm talking about.

Szario 1 - Creating / Editing a CWP through the configuration of common objects
  • Browse to "Configuration > Common objects > Authentication > Captive Web Portals"
  • Click to "Add"
  • Click to "Save"
  • Saved successfully
  • ...
  • Edit the created Captive Web Portal
  • The settings are not saved and it's also not possible to switch to User Auth again. (It's not possible to disable UPA and also not to enable User Auth.
Szenario 2 - Creating / Editing a CWP through SSID settings
  • Edit or Create a SSID through Network policies
  • Enable CWP for SSID
  • Click to the CWP "Test" for Editing
  • Here we go, ... settings are correct
Hopefully it's a little bit clearer now.

Best regards,
Bernd