IOS 9 breaks client classification

  • 2
  • Question
  • Updated 2 years ago
Hello Everyone, with IOS being released this week and users updating to it we have been faced with the following issue.
Being a K-12 school users use their AD credentials to connect to Wi-Fi using Microsoft's NPS server.
Depending on client classification users are then assigned to different VLANs. Now since the arrival of IOS 9, that doesn't work anymore and the only reason I can come up with is that the HTTP user agent isn't correctly detected anymore.
Could that be right? 
Photo of Carsten Loemker

Carsten Loemker

  • 14 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 2
Photo of Crowdie

Crowdie, Champ

  • 960 Posts
  • 269 Reply Likes
A number of vendors have reported issues with DHCP fingerprinting of iOS 9 devices.  If you create a new "iOS 9" OS Object using the DHCP Option 55 parameters 1,121,3,6,15,119,252 does it correctly detect the iOS 9 devices?
Photo of Tony Schaps

Tony Schaps

  • 28 Posts
  • 8 Reply Likes
YES! Thanks, I delved into uncharted waters figuring out how to do it, and it worked! One note: the OS Type has to be called "iOS9" because a space in it, like "iOS 9" causes the config update to fail. Client classification is awesome once again! 
Thanks, Crowdie!

Photo of Kevin Gee

Kevin Gee

  • 54 Posts
  • 4 Reply Likes
Yep thanks, works for me too.
Photo of Carsten Loemker

Carsten Loemker

  • 8 Posts
  • 2 Reply Likes
Thanks heaps Crowd your hint worked like a charm