internal server error 500

  • 1
  • Question
  • Updated 1 year ago
We have a mix of AP350 and AP121 in a retail environment.  There is a about 15 across 3 different branches.  We have 2 SSIDs, one guest and one corporate.  They are all running the latest firmware vesions.

About 4 months ago we started to get this error on the guest WIFI "internal server error 500".  This has CWP auth only to OK terms and conditions to connect, thats all.  DHCP is handed out from the router on the guest VLAN.  DHCP lease is 1hr. What I have tried doing:

1. Rebooting all devices.
2. Refresh the CWP - remove, reboot, then reapply.
3.  Remove any firewall rules on the APs for that SSID
4.  Remove the config and reapply.

What I have generally found is that refreshing the CWP (or anything else) and doing a config reload on the device will make the CWP work fine and this error doesnt show, but only temp.  After about a day its back again.

I have looked at all the other tickets in the portal and they all go nowhere, i.e. there is no solution that someone says "oh this fixed it" that I havent tried.  Any help would be appreciated.  This is across all devices too, so not just one particular piece of hardware.
Photo of Brad Nightingale

Brad Nightingale

  • 4 Posts
  • 0 Reply Likes
  • frustrated

Posted 1 year ago

  • 1
Photo of Jonas Dekkers

Jonas Dekkers

  • 152 Posts
  • 29 Reply Likes
Last week I had the same error on my Guest internet CWP. So I will follow your post
(Edited)
Photo of Tony Andrews

Tony Andrews

  • 52 Posts
  • 5 Reply Likes
Same here.  I've called support on it in the past thinking I had a bad AP.  I go to Update--> Advanced--> Remove Captive Webpage Directory, Reboot, Push out a new config.  The results indicate that the Captive Web Portal Files were uploaded.  



Try to connect to the Guest SSID again and get the same Internal Server Error 500.

The only thing that has worked is to wipe the offending AP back to factory, Push a complete config update and go.  But that gets a bit annoying after a while.  
Photo of ICN2

ICN2

  • 5 Posts
  • 0 Reply Likes
https://community.aerohive.com/aerohive/topics/web-server-internal-error-on-cwp

Try with this solution, it fixed the issue for me. But 8 months ago it is still hapenning on some devices randomly.
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
I had this issue with AP121 and AP130 access points running the 6.5r4 firmware with the 6.6 HiveManager.  I upgraded the HiveManager to 6.8r7a, removed the captive portal pages and then reloaded them (no changes made).   This resolved the issue.
Photo of Szymon

Szymon

  • 15 Posts
  • 1 Reply Like
Same issue with one of my customers AP's, random AP's, random devices affected, unfortunately no solution found yet. I raised ticket with support but no joy so far.