HOW TO - Using Aerohive APs for Active/Passive site surveys

  • 5
  • Idea
  • Updated 3 years ago
  • (Edited)
A little how to for partners and clients that want to use Hive APs to perform active or passive surveys using site survey tools like Airmagnet or Ekahau. 

The problem: by default, HiveOS performs automatic radio shutdown if there is no network connection (AP is not connected to anything). This is generally a good thing but is not helpful when performing a site survey where we are predominately interested in WiFi metrics. 

Solution: Use the access-console SSID to perform the site survey. You can learn more about all the functions of the access-console on this link:

This setup can be performed in GUI or CLI. 


1. SSH or Console to the AP. There is a good section on how to do that in our Deployment Guide, Page 79 (

2. Enable the access console:
access-console mode enable
3. Configure the SSID that is going to be broadcast for the survey:
access-console custom-ssid <string>
Replace <string> with a meaningful name, like "Survey_SSID".

4. Apply the access security to prevent casual SSID association:
access-console security protocol-suite wpa2-aes-psk ascii-key <8-63 char string>
5. Apply the settings to the radios:
interface wifi0 ssid <string>
interface wifi1 ssid <string>
Use the same string name used in the access console setup in step n2.

6. Set the desired power level on the radios. You can use auto, but manual settings are more predictable. Use the same power settings you are planning for your actual deployment. You can set the power in dBm (EIRP) in the 1-20 range:
interface wifi0 radio power <number>
interface wifi1 radio power <number>
7. Start walking :).


Post feedback if you want the same guide for the GUI.


Photo of Gregor Vucajnk

Gregor Vucajnk, Official Rep

  • 74 Posts
  • 27 Reply Likes
  • super duper

Posted 4 years ago

  • 5
Photo of BJ

BJ, Champ

  • 373 Posts
  • 45 Reply Likes
Great tip Gregor.
Photo of jonah johnson

jonah johnson

  • 6 Posts
  • 0 Reply Likes
This was great! Thanks for the awesome how-to.
Photo of Martijn Kuijlaars

Martijn Kuijlaars

  • 7 Posts
  • 0 Reply Likes
Our SSID isn't broadcasting in 5,0Ghz, we have followed these steps. Can you tell me the command I missed?
Photo of Jade Rampulla

Jade Rampulla

  • 36 Posts
  • 1 Reply Like
Excellent article. I'd recommend setting the power to 15 for wifi0 (2.4GHz) and 20 for wifi1 (5GHz).