How to configure BR-200 for external DHCP when using VLAN on SSID and ports?

  • 1
  • Question
  • Updated 4 years ago
  • Answered
I've got a BR-200 that I use for training purposes. The BR-200 has access ports configured to be native in VLAN 2. It also has an SSID configured that is assigned to VLAN 2 as well.
Attached to one of the access ports is a DHCP server. 

When wired clients request a DHCP offer everything works fine, but when a wireless client requests a DHCP offer the request seems to be filtered out in the BR-200.

Using static addresses both wired and wireless clients can communicate with each other and with the outside world via the WAN port.

This tells me that there is bridging between the wireless SSID and the access ports using the same VLAN.

How can I stop the BR-200 from filtering the DHCP request?
Photo of Marco Verleun

Marco Verleun

  • 6 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Brian Ambler

Brian Ambler

  • 245 Posts
  • 126 Reply Likes
Hi Marco,

What you are describing should be possible, though I'll admit that I have not tested such a configuration. If you have the branch router configured not to serve DHCP on the network assigned to VLAN 2, then you should have no issues, though without knowing the details of your configuration I cannot be sure. However, it should be noted that setting up an external DHCP server on another VLAN (say VLAN 3) then this will not work as it would require IP Helper/DHCP Relay support which the BR200 does not currently support.

To disable DHCP service on VLAN 2, navigate to the network assigned to VLAN 2 and uncheck the box for "Enable DHCP server"


I suspect that the issue you are running into is that the DHCP server on the BR200 is by default set to authoritative, which is interfering with your second external DHCP server. There is no option to disable the DHCP server from being authoritative, but if you look in the CLI you can see the full details of the DHCP server configuration.

What is visible from the GUI


What is visible from the CLI
Neptune#sho int mgt0.2 dhcp-server 
DHCP server parameters on interface mgt0.2 (VLAN 850).
DHCP server: enabled
Authoritative-flag: enabled <====
Arp-check: enabled
Lease time: 86400 secs
Netmask: 255.255.255.0
Default gateway: 10.50.1.1
NAT support: disabled
DNS Server: 10.30.1.20 10.200.20.20
NTP Server: 10.200.20.20
WINS Server:
Domain name: mydomainname.com
IP pools:
10.50.1.100 - 10.50.1.199
Hope this helps

Photo of Marco Verleun

Marco Verleun

  • 6 Posts
  • 0 Reply Likes
Hello Brian,
I've sent you  a private mail. For the viewers a short summary: I've had it working but can't figure out how. It stopped working after a full configuration reload and to my knowledge I didn't change anything.
The DHCP server on the BR-200 is turned off, but even turned on it should allow DHCP requests to pass through. It's up to the client to decide which DHCP Offer to accept if there are multiple DHCP servers on the network segment.

For me it is essential that the Wi Fi network and access ports bridge all traffic transparent because Apple's Netboot protocol is an extension of the DHCP protocol and necessary for me when deploying classrooms. Of course I prefer to do this wired, but some Mac products only connect wireless...

I'll check the Authoritative bit tomorrow.