How can I force a wifi client to connect to the closest / stongest AP when it wants to connect to a AP farther away?

  • 1
  • Question
  • Updated 4 years ago
  • Answered
I have some clients that are connecting to APs that are farther away even when the closer AP is working for other users. I've got about 20 people on the AP it's using now and about 12 on the one it should be using.
I was able to use a third party app to connect to the stronger AP, but it would be better to have it done native with Windows 8.1.
Photo of Ed Hammond

Ed Hammond

  • 2 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Brian Powers

Brian Powers, Champ

  • 391 Posts
  • 91 Reply Likes
In most all situations, clients make all of the decisions of when/where to roam/associate/re-associate. That said, you can influence and or control which APs they are capable of connecting to.

One way of doing this is by disabling some of the lower data rates that they would be using at the edge of the cell of the far AP. Essentially if you turn off the 6 Mbps data rate on the 5 GHz radio, clients will not be able to associate to that particular AP if the best data rate they can get is 6 Mbps. This would all but force them to look elsewhere for a better connection.

You can also turn down the output power of the AP to shrink the overall RF coverage footprint of the AP. This can be done on a per AP basis, whereas the data rates are done on an SSID (so all of your APs would be the same for data rates for a particular SSID).

Some client devices give you some control of roaming aggressiveness and other tweaks you can tinker with. Most of those are located under the Advanced tab on the device driver window from Control Panel -> Device Manager -> Wifi NIC.

Bear in mind I don't recommend making any drastic changes as you could bring about other issues by making these changes. Some client devices have issues connecting when certain data rates are disabled. Turning down the AP radio power could induce coverage holes in your deployment.

Make small incremental changes. And document what changes you make so you can quickly revert them if issues pop up later that could be related to these changes.
Photo of Crowdie

Crowdie, Champ

  • 965 Posts
  • 270 Reply Likes
A wireless client roams because their connection to an access point becomes "unacceptable".  What each wireless card vendor defines as "unacceptable" is their "secret sauce" and is not made public but is normally a combination of:

  • RSSI dropping below a predefined level

  • SNR dropping below a predefined level

  • Transmit error percentage rising above a predefined level

  • Receive error percentage rising above a predefined level

If your wireless network is dense then you can expect that some wireless clients will not roam as perfectly as you would like but this is only an issue if performance is adversely affected.

As Brian advised, be very careful adjusting the transmit power of your access points as you can easily create a situation where the wireless client is struggling to communicate with the accedes point or vice versa.  If the wireless client is struggling to communicate with the access point the access point will log this as a receive error.  If the access point is struggling to communicate with the wireless client the access point will log this as a transmit error.  These errors can be shown in HiveManager and for a data network they should not be above 10% while for a voice network they should not be above 2%.  Either way having a power mismatch can result in higher transmit or receive errors which will adversely affect the wireless client's performance.

For the interest of anybody reading this the rule of thumb for increasing the coverage area of an access point with omni-directional antennas is to increase the gain rather than the transmit power.  The gain is determined by the antennas utilised by the access point.  If you are using internal access points, such as the AP121 or AP330, you cannot change the antennas as their are internal.  Therefore, when you are selecting the access point with internal antennas you need to be really careful to check the gain on the antennas.

If you are worried above the performance complete an iPerf test with both access points and see if you really have a performance issue or the wireless clients are just not roaming as nicely as you would like.
Photo of Ed Hammond

Ed Hammond

  • 2 Posts
  • 0 Reply Likes
Thanks for the great advice guys!
We solved the problem by replacing the cheap Chinese USB Wifi adapters.
The Optiplex 9010 All-in-one we were using had a slot for an Intel wifi card that worked perfect.