How to start troubleshooting bad data rates?

  • 1
  • Question
  • Updated 3 years ago
  • (Edited)
How do I start troubleshooting bad datarates for Wifi? 
I have two AP230 on a location. HiveOS 6.4r1. I have deployed two SSID on both AP, on both 2,4GHz and 5GHz with basicly all settings default but WPA2 PSK with AES encryption security settings. 

Users are experiencing low data rates on the wifi network. Low data rates are 15 Mbps down, 8 Mpbs up on the clients. When connected to ethernet in the same LAN the traffic is 20 times faster, (maxing out the 300Mbps on ethernet). 

The problem has occured on different clients, so it is obviously a problem on the AP.

I have looked around in the Hivemanager and I really don't know where to start looking when troubleshooting these type of problems.

Things I've done:

Set AP's to automatically scan for best channel based on 1-6-11 settings. They seem to have solved to channel 1 and 11. The 2,4Ghz band use 20MHz channel width, and 5GHz use 80MHz channel width. Problems occur on both radios.

Monitor affected clients -> "Radio health, Network health and Application health" all green at "100".
RSSI ~-61dBm. SNR ~30dB. About the same on all clients, both in 5GHz (802.11na) and 2,4GHz (802.11ng).
I can not see any TX/RX frames dropped in the Statistic details. Bit rate Success distribution percentage is near 100% all the time.

On the SSID: 
Check all three streams are available. Rate settings to default 2,5GHz 1Mbps, 2Mbps, 5.5Mbps, 11Mbps basic, rest optional. On 5.0Ghz 6Mbps, 12Mbps, 24Mbps basic, rest optional.
MCS rate settings 0-23 are all set to optional. WMM enabled.

The AP:
Enabled background scanning, auto switch channel if RF interference of 25% is reached. Max transmit power of 20 dBm, channel width of 20MHz. Basicly everything is set to default for 802.11g/n mode, and 802.11a/n/ac mode.

Here is log on a client I monitored
http://pastebin.com/raw.php?i=8hhitEzK

Clients are macbook pro 2014.
Photo of Olof

Olof

  • 2 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Andrew Garcia

Andrew Garcia, Official Rep

  • 368 Posts
  • 120 Reply Likes
Sounds like your reported throughput is 15 down and 8 up, but what are the actual data rates that the client reports?  On a MBP, you can hold down the option key and press the wifi symbol in the top bar.  Look for TX Rate and PHY mode.  

The SNR and RSSI you report should be more than adequate to get you a good data rate.

One stab in the dark, make sure that WMM is enabled on your SSID.  Disabling WMM on a SSID will automatically throttle you back to 802.11a/g speeds.
Photo of Andrew Garcia

Andrew Garcia, Official Rep

  • 368 Posts
  • 120 Reply Likes
If you are feeling adventurous, you can also look at bidirectional data rates from the AP CLI.  Console or SSH into the AP, and enter the command show station <macaddress> for a client connected to the AP.  You will see a second by second recap of the data rate in both directions...

It will look like this...

Pow  txrate  txpkts txbytes  rxrate  rxpkts rxbytes

 -65(30)   72.2M     526 158.13K     24M    2145 171.60K

 -65(30)   72.2M     526 158.13K     24M    2145 171.60K

The first bolded number shows the data rate the AP used to send to the client, and the 2nd bolded number shows the data rate the client used to send to the AP.

If the numbers cap out at 54, there is a good chance you are stuck using legacy data rates, which can be caused by the use of WEP or TKIP for security or by disabling WMM.

If you see numbers higher than 54, then you have a different problem.

Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
Another option is to run iPerfv3 on a laptop to see your throughput.  I find this can sometimes reveal more than the data rates.  There is an iPerf server in the Aerohive access points or you could run an iPerf server on a LAN server, laptop or Desktop PC.

If you look in your radio profiles do you have the low data rates enabled?  In particular having the 802.11b data rates (1, 2, 5.5 and 11 Mbps in the 2.4 GHz spectrum) can severely reduce your throughput.
(Edited)
Photo of Terence Fleming ThinkWireless

Terence Fleming ThinkWireless, Champ

  • 79 Posts
  • 27 Reply Likes
First, per Andrew, start by checking the PHY rates and see if they are consistent with the RSSI/SNR readings.

Then, per Crowdie, SHORTEN THE CHAIN over which you are measuring the throughput to as much as possible. I cannot stress this enough. I'm guessing that since you used the phrase "obviously a problem on the AP" you may not trust the AP as your iPerf server. :-)

I use JPerf, which is iPerf in a user-friendly Java wrapper. Run your test from a wireless client running JPerf as a client, across the air to the AP, through the patch cord to the switch, to another port on the same switch, to another laptop on a wired connection to that switch.

Now you have a consistent and portable test setup, and it will be very straightforward for you to swap out components at Layer One until you isolate the issue.
Photo of John Fabry

John Fabry

  • 28 Posts
  • 8 Reply Likes
totally agree with Crowdie, Kill the low rates. It makes a world of difference. I f your clients are MACs they will hold slow connections all the way down to -78db even if your sitting under a -50db signal. Silly MACs.