how to enable diversity on ap390?

  • 1
  • Question
  • Updated 3 years ago
  • Answered
I have an AP390 I'm trying to measure RF output power of; the unit is not connected to any network, just CLI via console. I can change radio power and radio channel correctly via the appropriate CLI commands, but I cannot work out the correct syntax for enabling diversity. AP390 CLI gives "interface radio antenna diversity ".

I have tried the following:-
interface wifi1 radio antenna diversity ENABLED
interface wifi1 radio antenna diversity 1
interface wifi1 radio antenna diversity TRUE

but these just result in an error, so what is the correct syntax, where is it documented?
Photo of andy inman

andy inman

  • 4 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Brian Powers

Brian Powers, Champ

  • 396 Posts
  • 92 Reply Likes
On an AP350, just <interface wifi0/1 radio antenna diversity> enables it.  And adding no in front of it will disable it.

Not sure if/why it'd be any different on an AP390 but I don't have one to check.
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
Brian is exactly right. There is no need to explicitly set this, it is implicitly the default. 
Photo of andy inman

andy inman

  • 4 Posts
  • 0 Reply Likes
OK thanks guys I'll try that out this morning.
Photo of andy inman

andy inman

  • 4 Posts
  • 0 Reply Likes

OK me again

One correction - it's an AP141 I'm using at the moment, haven't gotten round to trying this on our AP390 units, apologies for misleading info.


Anyway, I've tried inserting 'no' in various places into the diversity command, but the AP rejects the command:-


Have I still got the syntax wrong?

On power up the AP defaults to diversity off, and sending 'radio antenna diversity' does indeed enable diversity, so I can switch it on but not off.


Cheers.........~A~

Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
You got the syntax wrong.  If you wish to turn diversity off, the syntax is

no interface wifi0 radio antenna diversity

On power-up, unless you have previously changed the device config and saved that, diversity is ON. It's implicitly on, so won't show up in a "sh conf runn" output.

Remind us all again, what are you trying to accomplish?
Photo of andy inman

andy inman

  • 4 Posts
  • 0 Reply Likes

OK thanks that work fine.

I'm attempting to do some basic air interface measurements (Transmit power, spectrum mask etc.) on the AP with and without diversity.