How do I add a device that doesn't support wifi to the network?

  • 1
  • Question
  • Updated 3 years ago
  • Answered
I tried connecting it to one of the Ethernet ports on the nearest aerohive and configuring that port to bridged mode. This didn't seem to work. What is the best way to do this? This is not a networking device I am trying to connect, it is a device with an Ethernet port that I want to be able to access via the network but which does not support wifi.
Photo of Omar

Omar

  • 13 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
You are best off using a separate switch before the AP.
(Edited)
Photo of Omar

Omar

  • 13 Posts
  • 0 Reply Likes
Any switch will do? what mode does the ap need to be set to at that point?
Photo of Omar

Omar

  • 13 Posts
  • 0 Reply Likes
Any switch will do? What mode does the ap need to be set to at that point?
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
No changes need to me made to the AP unless you are using one in a router mode and need full connectivity between the wired and wireless clients. (Unlikely)

If you are not using VLANs, any unmanaged switch will do.

If you are using VLANs, you will need a switch that supports VLANs and for it to be configured correctly to pass those are are desired/in use.
(Edited)
Photo of Omar

Omar

  • 13 Posts
  • 0 Reply Likes
I tried a switch and it doesn't seem to work. I plug the switch to the aerohive device in eth1 and I plug a laptop into the switch to test and there seems to be no connectivity. The laptop obtains an IP with a 255.255.0.0 netmask. I know that machines that are actually working on that network have a 255.255.255.0 netmask. Furthermore, the laptop obtains a similar ip even if the aerohive is not plugged into the switch at all. Also, the light over the port that the aerohive plugs into always stays off, it never lights up or blinks. Given all this evidence, I'm fairly certain plugging the switch into the aerohive is having no effect whatsoever. Unless I need a crossover cable instead of Ethernet (does that matter anymore in this day and age?) I'm thinking there has to be a setting on the aeorhive I need to configure. Let me know if you have any ideas.
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
Why are you plugging the switch in to eth1 on the AP?

The AP is not going, by default, to act as a bridge between eth0 and eth1. While this can be configured, you normally wouldn't want to do this. Switches use special chips that can do this at line rate, an AP would be CPU bound to achieve the same thing.

I assumed and am assuming that you have a cable going in to eth0 on the AP.

You conceptually would be best to put the switch on to that existing cable, and then plug the AP in to the switch, so just eth0 on the AP will be populated.

You want both the uplink and the AP to be plugged in to the switch.

I'm assuming that you don't have VLANs in use in this environment.
(Edited)
Photo of Omar

Omar

  • 13 Posts
  • 0 Reply Likes
eth0 provides the power in addition to backhaul. I'm not sure it will do that properly if I plug a switch in between.
Photo of Andrew Garcia

Andrew Garcia, Official Rep

  • 368 Posts
  • 120 Reply Likes
Assuming ETH0 is the AP backhaul connection, you want to modify the Ap settings and switch ETH1 to Bridge-Access.  Under Advanced Bridge Configuration, you can assign a user profile to the port, allowing you to set a VLAN or firewall policy.  Then you have to push a complete config update to the AP, which will reboot it.


you can also configure ETH1 as a trunk port by selecting Bridge-802.1Q, 

This is all spelled out in Help, by the way.
http://www.aerohive.com/330000/docs/help/english/6.4r1/hm/full/help.htm#config/APs/manAPDconfig.htm
Photo of Omar

Omar

  • 13 Posts
  • 0 Reply Likes
Thanks, but that didn't seem to work either. In addition, my advanced settings don't look like yours. Mine show a "Static MAC Entries" section instead. There is no User Profile option.
Photo of Andrew Garcia

Andrew Garcia, Official Rep

  • 368 Posts
  • 120 Reply Likes
What device are you using and what HiveOS version (version number + Express or Enterprise?

Also, is your Power over Ethernet 802.3af or 802.3at?  If you are using 802.3af and an AP230, the 2nd Ethernet port is not active.  You need to provide 802.3at or use a power brick.
Photo of Omar

Omar

  • 13 Posts
  • 0 Reply Likes

The devices in question are AP320 and AP340. I've been testing it on an AP340 but once I know how to get it working I'm taking the stuff over to an AP320 which is what is running at the physical location these devices are going to need to be plugged into. The power is 802.3af. Hive Manager shows version: Express 6.1r6a. Is this information still consistent with the theory that the port is inactive due to using af power?


Thanks a lot for your help.

Photo of Andrew Garcia

Andrew Garcia, Official Rep

  • 368 Posts
  • 120 Reply Likes
Photo of Omar

Omar

  • 13 Posts
  • 0 Reply Likes

Thanks. I've looked at the specifications and it seems my best path forward is to just replace the POE injectors. Looking at what's out there on amazon it looks like there is a huge price jump from $20 to $60. Is there anything wrong with these cheap ones?

http://www.amazon.com/iCreatin-Ethernet-Injector-1000Mbps-Compliant/dp/B00NRF9GQO/ref=sr_1_4?ie=UTF8...

Will that do the trick for me? Alternatively, do I want one that is at only rather than af/at?