HMOL NG not setting country code on AP230

  • 1
  • Question
  • Updated 2 years ago
I've just deployed 5 new 230s and I'm trying to set the country code.

When I select Assign Country Code from the Monitor -> Devices -> Actions menu it defaults to United Kingdom (826). 
When I set it to Norway (578)–which is the country code I want–the clients I've tested (two so far, both running OS X 10.11) report the country code of the WiFi network as being "US". 

I've confirmed this in the GUI (WiFi menu), System Profiler and WiFi Diagnostics.app.


The tech data dump for the devices reports:
Region Code:        World
Country Code:       578

so these are not FCC devices.

Should I just ignore this or do I have a real problem?
Photo of Arnor Kristjansson

Arnor Kristjansson

  • 4 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
Ignore it. We independently discovered a few weeks ago that in certain circumstances we are incorrectly setting the information element within beacons for country code to US, but do abide by the power levels and channel choices appropriate for the country code you've selected. Your APs are advertising more than one SSID, aren't they? 

This should be fixed in the upcoming HiveOS version 6.5 update and in HiveOS version 6.8r1. Both are nearly done and should be released within a month.
Photo of Arnor Kristjansson

Arnor Kristjansson

  • 4 Posts
  • 0 Reply Likes
Yes they are. Thanks for the quick reply!
Photo of Joakim Bo Löfman Carli

Joakim Bo Löfman Carli

  • 5 Posts
  • 3 Reply Likes
Hi Mike, 

Do you know if this is resolved in the 6.5r4 update? I cannot find any information about it in the 6.5r4 release notes.

Best Regards
Joakim  
Photo of Joakim Bo Löfman Carli

Joakim Bo Löfman Carli

  • 5 Posts
  • 3 Reply Likes
Hi, 

Quick update, the issue seems to be resolved in 6.5r4 release. 

Best Regards
Joakim