HiveAP 230 configuration been rollbacked

  • 1
  • Question
  • Updated 3 years ago
I'm doing an update and activate configuration from HMOL to HiveAP230.
But the HiveAP show error that the configuration been rolled back.
What cause this problem?

Thanks
Photo of hoang Tung

hoang Tung

  • 2 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Ruwan Indika

Ruwan Indika

  • 66 Posts
  • 22 Reply Likes
Hi Hoang,

I think the AP fail to connect to HiveManager using capwap after the config upload. That will cause the AP to rollback to the previous configuration and attempt to establish capwap connection with the HIveManager. This could be cause by DNS server not being reachable, or the AP cannot access the HiveManager due to some miss configuration in IP address configuration.  Please double check you configuration. 

If you have console access to this AP, check the following after config upload,

show L3 interface         # shows the IP address     
show dns                     # shows the DNS server address
show capwap client     # Show the capwap client information
capwap ping hm-xxx-xxx.aerohive.com  # ping to Hivemanager using capwap
Photo of tung hoang

tung hoang

  • 40 Posts
  • 0 Reply Likes
Hi Ruwan,
Thanks for your help.
What do you mean by DNS server not being reachable?
I took some screenshots here, it look like normal test


so you are suggesting we check the DNS server?

Cheers
Photo of Hans Matthé

Hans Matthé

  • 131 Posts
  • 28 Reply Likes
Hi Hoang

Did you changed the IP settings? We see it sometimes when people configure fixed IP-settings and have bad DNS-settings. Firstly they receive the IP-settings (inclusive the DNS-settings) from a DHCP server, but when they configure the fixed IP, Aerohive will use the DNS server configured in the Hivemanager, and sometimes this is not correct.
Photo of tung hoang

tung hoang

  • 40 Posts
  • 0 Reply Likes
Hi Hans,
I assign Static IP for APs.
Can you please be more specific by "Aerohive will use the DNS server configured in the Hivemanager"?
Thanks
Photo of Ruwan Indika

Ruwan Indika

  • 66 Posts
  • 22 Reply Likes
Hi Hoang,

From the information provided. The DNS server is set to 208.67.222.222, 208.67.220.220. In your network clients cannot use this DNS server. 

Please set your DNS server address to 192.168.55.11 under Configuration --> Network Policy --> Additional Settings --> Management Server Settings --> DNS server.

(Edited)
Photo of tung hoang

tung hoang

  • 40 Posts
  • 0 Reply Likes
Hi Ruwan,
You were right, yes the DNS were 208.67.222.222 and 208.67.220.220
Here is the screenshot:


But what happen when I set the DNS to my server? I check with other HMOL, they are same and work fine.

Thanks
Photo of Ruwan Indika

Ruwan Indika

  • 66 Posts
  • 22 Reply Likes
Hi Hoang,

1) Create a New DNS server object,



2) Apply that to the Network profile,

Photo of tung hoang

tung hoang

  • 40 Posts
  • 0 Reply Likes
Yes, It's done. 
But my question is what cause this problem? I have other client with same DNS, but they have no problem at all.
Thanks
Photo of Hans Matthé

Hans Matthé

  • 131 Posts
  • 28 Reply Likes
Hi Hoang

I think you have to troubleshoot the network instead of the Aerohive solution. Did you tried to plugin a laptop in the same port with the same settings?
Photo of tung hoang

tung hoang

  • 40 Posts
  • 0 Reply Likes
Yes, I just recognize the school has a bad dns.
Here is the result:
Photo of tung hoang

tung hoang

  • 40 Posts
  • 0 Reply Likes
Thanks Ruwan and Hans,
At least I know what should I deal with.

Cheers