Guest not redirected to captive portal when url starts with https://..

  • 2
  • Question
  • Updated 7 months ago
Hello everybody 

Sometimes  we have the issue that a Guest user is not able to see the captive web portal with use policy acceptance page. We saw that the redirection works when they try to go to a HTTP page, but it goes wrong when they have an URL trying to surf to an HTTPS page. then it says cannot display this page etc ..  

How can we fix this issue? 

Thanks in advance.. 

JY
Photo of joy

joy

  • 21 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 2
Photo of Hans Matthé

Hans Matthé

  • 42 Posts
  • 2 Reply Likes
At the captive webportal settings you can configure to use https, add a certificat and a webserver that responds to the certificat (Do you use HMOL or Hivemanager NG?). Check the certificate chain if it is an intermediate, we had some issues on Android devices that keeps mention that the https site is still untrusted, on Windows devices and iOS it all went well.
Photo of joy

joy

  • 21 Posts
  • 0 Reply Likes
Hi Matthé, thx for your reply 

We use the hivemanager on prem. I saw the setting for enabling https. and I understand your suggestion, but don't have a webserver for this. Is there no other way to intercept this https://.. attempt to internet access.. end redirect to the captive portal..

Thanks
JY 
Photo of Scott

Scott

  • 4 Posts
  • 0 Reply Likes
Did you find a solution for this?  We use the on prem version too but I'd rather not setup a server just to deliver a splash page for https.