Force NTP Update on AP

  • 1
  • Question
  • Updated 4 years ago
  • Answered
We have just updated a few test APs with the new firmware and noticed that the clocks on 2 of the 5 AP’s were still set to 1970. (This caused problems for PPSK users not being able to connect.) After a full update & second reboot the time stayed the same.

We are reducing the NTP update time from 1 day down to an hour, but is there a way to manually force an AP to sync its time with the NTP server?
Photo of sx

sx

  • 25 Posts
  • 2 Reply Likes

Posted 4 years ago

  • 1
Photo of Andrew MacTaggart

Andrew MacTaggart, Champ

  • 483 Posts
  • 86 Reply Likes
I don't any commands to perform an ntp update

you could set the clock closer to your time with the clock command via ssh

clock date-time 2014-04-07 10:17:30

out of curiosity

you have updated to 6.1r3b
what AP model

is NTP setup using the hive to sync
or do you have an internal NTP server
or are you using one on the internet

there is a command no ntp enable
I would be interested if doing a no ntp enable and then ntp enable would force an update




Photo of sx

sx

  • 25 Posts
  • 2 Reply Likes
This was on AP330's. They have been set to use internal NTP server, and not the Hivemanager or Internet time servers.

If it happens again I will try the "no ntp enable" and "ntp enable" trick and see what happens.
Photo of Andrew MacTaggart

Andrew MacTaggart, Champ

  • 483 Posts
  • 86 Reply Likes
just tried it on test AP but running
Version:            HiveOS 6.0r2d release build
Platform:           AP370

ETSAC#clock date-time 1970-01-01 12:12:12
ETSAC#show clock
      1970-01-01  12:12:15  Thursday
ETSAC#
ETSAC#no ntp enable
ETSAC#show clock
      1970-01-01  12:12:34  Thursday
ETSAC#ntp enable
ETSAC#show clock
      2014-04-07  13:38:49    Monday
ETSAC#






(Edited)
Photo of sx

sx

  • 25 Posts
  • 2 Reply Likes
Thanks - that's really helpful.
Photo of Carsten Buchenau

Carsten Buchenau, Champ

  • 356 Posts
  • 117 Reply Likes
Also, keep in mind that the only way to verify if an Access Point really has the correct time set is by CLI command:

EC-Wifi-LF-Office#show clock
      2014-04-07  13:41:35    Monday
EC-Wifi-LF-Office#

And as we are on this topic already, here are some tips to make sure NTP setting are correct everywhere:

- "Sync time with Hivemanger" still uses NTP, just the HM's IP address is used as NTP server automatically. So you still need to make sure that local firewall rules allow outgoing NTP traffic, and the Firewall admin in front of the Hivemanager you are using has to ensure that incoming NTP traffic is allowed
- If you are using host names as NTP server, make sure your APs use a working DNS settings...
- Make sure you have the correct time zone and NTP settings everywhere:
-- Network Policy / Additional Settings / Management Server Settings / NTP Server
-- Hivemanger VHM / Home / Administration / HiveManager Settings / System Date/Time
-- Hivemanger root / Home / Administration / HiveManager Settings / System Date/Time
-- Admin account settings (time zone only)

Otherwise your reports might not display the correct times...

carsten