Epson TM-u220 and a AP130

  • 1
  • Praise
  • Updated 2 years ago
  • (Edited)
Epson TM-u200 kitchen printers do not connect to SSID from AP130.

I have serval of these printers, and they connected ok with an Old (Buffalo Airstation) AP.
Ive put the AP130 in its place, and other devices (iphones/ laptops etc) can connect, but not the printers.

I can connect to the printers via a usb cable to check the config, and they are hardwired to look for channel 11 (or 5) and use  WPA/WPA2-PSK.

I have configured the AP to use the 2.4GHz as Chanel 11 ( the 5ghz config does not allow me to pick either of these channels).


Can someone point me in the correct direction please ?

thanks
Photo of IT Manager

IT Manager

  • 4 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Brian Powers

Brian Powers, Champ

  • 396 Posts
  • 92 Reply Likes
First guess would be the data rates selected on your SSID.  Some printers require the legacy data rates to be enabled (1, 2, 5.5, 11) to work, even though they are 802.11g/n capable.  
Photo of IT Manager

IT Manager

  • 4 Posts
  • 0 Reply Likes
>Hi Brian. How do I enable these rates on a AP130? thanks
Photo of Brian Powers

Brian Powers, Champ

  • 396 Posts
  • 92 Reply Likes
A couple different ways.  Under your network policy for the gear, you can select the SSID object that the printer is trying to connect to.  Under Optional Settings and Radios and Rates, what is selected for the "2.4 GHz 11b/g Rate Setting"?  Optionally, depending on the band the printer is trying to associate to, how is the "5.0 GHz 11a Rate Setting" configured?

Standard default settings would be "Basic" for 1, 2, 5.5, 11 and "Optional" for all other rates in the 2.4 GHz section. 

Standard defaults for the 5.8 GHz section would be "Basic" for 6, 12, 24 data rates and "Optional" for all others.

This would give the printer the best chance to associate.  You could tinker with the data rates after that to determine which rate is required (needs to be set to Basic) to support this printer.  The alternative option would be to capture a probe request frame from the printer and to dig into its capabilities there.  But that may be more than you're capable of doing (I don't know what tools you have at your disposal or your technical level).

Also, I wouldn't set the printer to look for a specific channel, unless your APs are statically configured for a specific channel as well.

Hope this helps!
Photo of IT Manager

IT Manager

  • 4 Posts
  • 0 Reply Likes
HI Brian,

2.4ghz is set to 802.11 b/g. under this, 1,2 & 5.5 = N/A. 11 = basic and the other are Optional.

5ghz is set for 802.11a. under this, 6,12,and 24 are Basic, the others are optional.

I'll amend 2.4ghz 1,2,5.5 to basic and see if the printers appear.

thanks
Photo of IT Manager

IT Manager

  • 4 Posts
  • 0 Reply Likes
Hi,

When I change the 2.4ghz settings, and save, and then save again, and then goto  Deploy Policy, select my AP , Upload, and select Delta configuration,.. it looks like its doing something, but when I go back in and check the changes, they have gone back to defaults.
Same happens if I try the Completer upload option.
I make sure that the upgrade HiveOS option is unchecked.
could some one please advise as to what I am doing that makes the AP NOT take the changes ?
I cannot see anything in the Troubleshooting logs either.

thanks
Photo of Bill W.

Bill W.

  • 222 Posts
  • 35 Reply Likes
Do a client monitor to get an idea of what is going on.
Photo of Bill W.

Bill W.

  • 222 Posts
  • 35 Reply Likes
Also, channel 11 (channels 1-11 in the US) is only available in 2.4 GHz; hence why you can't configure it in 5 GHz.