Enable SNMP on access points

  • 1
  • Question
  • Updated 2 years ago
  • Answered
How do i enable SNMP on Aerohive AP121?

thanks
Photo of shahzeb asif

shahzeb asif

  • 4 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
The SNMP settings are stored in the network policy applied to the access point.  To access the SNMP settings within HiveManager select Configuration -> Network Policies -> [Network Policy] -> Additional Settings -> Management Server Settings -> [Click on the "+" icon to the right of the SNMP Server field].
(Edited)
Photo of shahzeb asif

shahzeb asif

  • 4 Posts
  • 0 Reply Likes
that requires SNMP server. we are using solarwinds NPM for monitoing. to detect the aerohive ap i need to put Community String and Read/Write Community String. how can i configure those in AP?
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
From the access point I believe you will need to utilise the snmp trap-host command - http://www.aerohive.com/330000/docs/help/english/documentation/cli_guide_ap121-141_6-1r6.htm#cmd1151.

For information on all the CLI SNMP commands go to http://www.aerohive.com/330000/docs/help/english/documentation/cli_guide_ap121-141_6-1r6.htm#cmd1147.

If you are using a version of HiveOS earlier than 6.1r6 you will need to find the CLI Reference Guide appropriate for your access point and HiveOS version at http://www.aerohive.com/330000/docs/help/english/6.1r5/hm/full/Content/ref/doc.htm.


(Edited)
Photo of shahzeb asif

shahzeb asif

  • 4 Posts
  • 0 Reply Likes
tried

snmp reader version any community public x.x.x.x

but still not working.
  
Photo of Bill W.

Bill W.

  • 222 Posts
  • 35 Reply Likes
You don't need to enter any CLI commands on the APs.  You are most likely missing a setting in your Network Policy.

In addition to setting up the SNMP Server in the Management Server Settings in the Network Policy as Crowdie stated, you also need to enable SNMP in the Traffic Filter of the Network Policy.

It's in the Additional Settings too.  So go to Configuration->Network Policies->[Network Policy]->Additional Settings->Traffic Filter Settings.  Then you can either modify the default filter (def-service-filter) or create a new one.  Either way, you need to click the check box for Enable SNMP.  SNMP (along with Telnet) are disabled by default.

(Edited)
Photo of shahzeb asif

shahzeb asif

  • 4 Posts
  • 0 Reply Likes
thanks a lot this worked out.
Photo of Bill W.

Bill W.

  • 222 Posts
  • 35 Reply Likes
You're welcome.  Glad I could help.
Photo of Andrew Clark

Andrew Clark

  • 4 Posts
  • 0 Reply Likes
This was the same problem i was having as well. Thanks for the filter tip.
Photo of Andrew Clark

Andrew Clark

  • 4 Posts
  • 0 Reply Likes
What if both the Traffic Filter and the SNMP server are configured yet it still doesn't work? As you can see in my comment above at one point it was, but now isn't.
(Edited)
Photo of Justin Merwin

Justin Merwin

  • 18 Posts
  • 0 Reply Likes
I know this is an old post but I have the exact same issue
Photo of Dennis

Dennis

  • 29 Posts
  • 1 Reply Like
Hi, 

You could check in your device template, and check the UPLINK port. snmp is not enabled by default.

Kind regards,

Dennis