Desirable trunking

  • 1
  • Question
  • Updated 2 years ago
  • Answered
Is anyone else trying to use desirable trunking when connecting an Aerohive AP to a Cisco Catalyst PoE switch? I'm not having an luck with it - it does not start trunking.

Port config looks like this:
interface GigabitEthernet1/0/21
switchport access vlan 341
switchport trunk native vlan 341
switchport trunk allowed vlan 340,341
switchport mode dynamic desirable
!
Photo of Fraser Hess

Fraser Hess

  • 60 Posts
  • 7 Reply Likes

Posted 5 years ago

  • 1
Photo of Brian Ambler

Brian Ambler

  • 245 Posts
  • 126 Reply Likes
Hi Fraser,

I set the mode on port 22 on a Catalyst 2950 in my lab and I am also seeing a similar issue. When I connect an AP330 in my lab to the Catalyst 2950, the mode of port 22 (which is set to dynamic desirable) does not get set to trunk, but rather access. I have even tried rebooting the switch, but the mode stays as access. However, if I set the switchport mode to trunk (which is the configuration I normally use) I see no issues.

Oberon#sho run int fa0/22
Building configuration...

Current configuration : 177 bytes
!
interface FastEthernet0/22
description *** Lab AP ***
switchport access vlan 2001
switchport trunk native vlan 2001
switchport trunk allowed vlan 2001-2004,2101-2104
end

Oberon#sho int fa0/22 switchport
Name: Fa0/22
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: On
Access Mode VLAN: 2001 (VLAN2001)
Trunking Native Mode VLAN: 2001 (VLAN2001)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: 2001-2004,2101-2104
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false

Appliance trust: none

Looking at Cisco's documentation for the various switchport modes, I doubt that our APs support dynamic mode. Setting the switchport to dynamic desirable requires that the port on the other side of the link support Dynamic Trunking Protocol (DTP) which is a proprietary Cisco protocol (More information can be found here and here.

From the Catalyst 2950 Desktop Switch Command Reference (found here) on switchport configuration:

switchport mode

Use the switchport mode interface configuration command to configure the VLAN membership mode of a port. Use the no form of this command to reset the mode to the appropriate default for the device.

switchport mode {access | dynamic {auto | desirable} | trunk}

no switchport mode

Syntax Description

access

Set the port to access mode (either static-access or dynamic-access depending on the setting of the switchport access vlan inteface configuration command). The port is set to access unconditionally and operates as a nontrunking, single VLAN interface that transmits and receives nonencapsulated (non-tagged) frames. An access port can be assigned to only one VLAN.

dynamic auto

Set the interface trunking mode dynamic parameter to auto to specify that the interface convert the link to a trunk link.

dynamic desirable

Set the interface trunking mode dynamic parameter to desirable to specify that the interface actively attempt to convert the link to a trunk link.

trunk

Set the port to trunk unconditionally. The port is a trunking VLAN Layer 2 interface. The port transmits and receives encapsulated (tagged) frames that identify the VLAN of origination. A trunk is a point-to-point link between two switches or between a switch and a router.

Defaults

The default mode is dynamic desirable.

Usage Guidelines

Configuration by using the access or trunk keywords takes affect only when you configure the port in the appropriate mode by using the switchport mode command. The static-access and trunk configurations are saved, but only one configuration is active at a time.

If you enter access mode, the interface changes into permanent nontrunking mode and negotiates to convert the link into a nontrunk link even if the neighboring interface does not agree to the change.

If you enter dynamic auto mode, the interface converts the link to a trunk link if the neighboring interface is set to trunk or desirable mode.

If you enter dynamic desirable mode, the interface becomes a trunk interface if the neighboring interface is set to trunk, desirable, or auto mode.

If you enter trunk mode, the interface changes into permanent trunking mode and negotiates to convert the link into a trunk link even if the interface connecting to it does not agree to the change.

The no switchport mode form resets the mode to dynamic desirable.

Trunk ports cannot coexist on the same switch.

To autonegotiate trunking, the interfaces must be in the same VTP domain. Trunk negotiation is managed by the Dynamic Trunking Protocol (DTP), which is a point-to-point protocol. However, some internetworking devices might forward DTP frames improperly, which could cause misconfigurations. To avoid this, you should configure interfaces connected to devices that do not support DTP to not forward DTP frames, which turns off DTP.

•If you do not intend to trunk across those links, use the switchport mode access interface configuration command to disable trunking.

•To enable trunking to a device that does not support DTP, use the switchport mode trunk and switchport nonegotiate interface configuration commands to cause the interface to become a trunk but to not generate DTP frames.

Hope this helps
Photo of Anoop Dawar

Anoop Dawar

  • 26 Posts
  • 16 Reply Likes
Fraser
We don't support DTP - it is a Cisco proprietary protocol as far as I know. Configuring Cisco switch to use switchport mode trunk should make this work.
Photo of christian jerick Go

christian jerick Go

  • 1 Post
  • 0 Reply Likes
Great article - BTW , if anyone needs a Copyright PTO/SB/30EFS , my wife saw a fillable version here http://pdf.ac/6zkyMU.