Is anyone else having issues with CWP redirections in Apple devices?

  • 1
  • Question
  • Updated 5 years ago
  • Answered
  • (Edited)
Hey guys,

Has anybody had issues with CWP redirections in OSX / iOS / Safari devices?

I had configured a PPSK SSID with self-reg and I couldn't associate a Macbook Pro (OSX 10.8.3) an iPad iOS 6.1.3 and and iPhone 4 iOS 6.1.3.
Photo of Erick Muller

Erick Muller

  • 35 Posts
  • 8 Reply Likes

Posted 5 years ago

  • 1
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
Erick,
Can you explain a little more about what aspect is not working for you? You say that the Apple devices cannot associate, do you mean that they cannot connect initially so they never see the CWP self-reg page, or after they associate they don't get presented with the CWP self-reg page, or ??
Photo of Erick Muller

Erick Muller

  • 35 Posts
  • 8 Reply Likes
Hi Mike,

I'm so sorry but I wrote associate instead of redirect, yes I know there's a lot of difference between them, is just that I was doing two things at the same time and I just mixed things.

I tested the next redirection scenarios:

Macbook Pro (OSX 10.8.3)
Safari 6.0.4: Redirection to Reg page Fails
Chrome 26.0.1410.65: Redirection to Reg Pag Successful, Redirection to Key page: Successful

iPad 3 (iOS 6.1.3)
Safari: Redirection to Reg page Successful, Redirection to Key page Fails
Chrome: Redirection to Reg page Successful (after Refresh), Redirection to Key page Fails (after refreshing the browser shows the Reg page again)
Opera mini: Redirection to Reg page fails

iPhone 4 (iOS 6.1.3)
Safari: Redirection to Reg page Successful, Redirection to Key page Fails
I haven't tested further with this device.

Again, I'm so sorry for the misunderstanding, I've tested with a Windows Phone 7 device and an Android 4.0.3 and everything worked as charm.

Thank you very much for your help
Photo of Erick Muller

Erick Muller

  • 35 Posts
  • 8 Reply Likes
I'm ashamed I couldn't figured it out this earlier, but as soon as I changed CWP to use http instead of https it worked!

As I think that this could be caused due to a certificate reason, are there any suggestions to make the redirection work with those devices using https?
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2491 Posts
  • 451 Reply Likes
Erick,

Think about this abstractly. If redirection could work with HTTPS before the secure TLS channel to a server has been established and the server's certificate validated (for the initially requested address), it would be a huge MITM security vulnerability in Web browsers.

Nick