CWP + WPA2 unreliable combination: guest SSID works if left open, Apple devices cannot connect if WPA2 PSK used

  • 1
  • Question
  • Updated 3 years ago
I'm new to Aerohive, but so far so good, except I'm trying to figure out why I can't add WPA2 encryption to the guest SSID I have configured on our 3 AP230s. It works ok with no security enabled, but for some strange reason our Apple devices (which is what we predominantly use) fail to connect when WPA2 PSK is enabled. On a Mac I see the "Connection timeout." error, while on an iPhone I'm told "Incorrect password" (although the password is definitely correct in both cases). On the other hand, I managed to get a ThinkPad to connect to it without similar errors (although the self-registration CWP failed to load on the first couple of attempts after the connection was made). Any ideas what the problem is and how to fix it?
Photo of Joe G Carroll

Joe G Carroll

  • 9 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Tony Schaps

Tony Schaps

  • 28 Posts
  • 8 Reply Likes
If you used the same SSID before with a different password, Apple products have a strange way of dealing with it. A quick way to test this is to change the name of the SSID by just one letter, and your results may be different. 
If this might be the case, go into the Keychain Access and search for the SSID name (with "All items" chosen at left) and delete any stored entries (and then change your SSID back).
If that works, I can give you instructions for iOS.
Photo of Tony Schaps

Tony Schaps

  • 28 Posts
  • 8 Reply Likes
And make sure WMM is enabled on the guest network... if not, try that first.
Photo of Joe G Carroll

Joe G Carroll

  • 9 Posts
  • 0 Reply Likes
Thanks for the tips, Tony. I'll try both tomorrow.
Photo of Joe G Carroll

Joe G Carroll

  • 9 Posts
  • 0 Reply Likes
Changed the SSID name and enabled WMM in the same step and, while I don't know which did the trick, the problem seems solved, I'm glad to report. Thanks, Tony!