Connection issue. Spectralink 8440, will not accept TKIP encryption

  • 1
  • Question
  • Updated 1 year ago
  • Answered
We are having a tough time setting up some phones...

One model, Unidata 7880, connects fine with WPA2-psk and TKIP

The other, Spectralink 8440, fails with that setup.

If I modify the SSID to use CCMP then the problem switches and I can connect the Spectralink but not the Unidata.

Neither phone has a setting for the TKIP or CCMP so I am stuck.

Any suggestions?
Photo of robert korn

robert korn

  • 13 Posts
  • 1 Reply Like

Posted 4 years ago

  • 1
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1026 Posts
  • 269 Reply Likes
First off, I hope you are using recent versions of HiveManager and HiveOS. If not, first please upgrade to the latest your entitlement will let you get to (we are currently at 6.1r2).

I suspect you have the SSID configuration Key Management parameter set for "WPA-PSK" and not "Auto-(WPA or WPA2)-PSK" and thus you don't have a selection for auto under "Encryption Method. Try changing the key management parameter. That instructs the AP to advertise availability of both crypto methods and the endpoints (your phones) should then choose what is appropriate for themselves.

If that still fails, then I would suggest contact your support representatives for additional troubleshooting guidance.
Photo of Nick Lowe

Nick Lowe, Official Rep

  • 2486 Posts
  • 448 Reply Likes
Can you run with two SSIDs in the worst case scenario that you cannot get them both working on one?
Photo of Crowdie

Crowdie, Champ

  • 960 Posts
  • 269 Reply Likes
According to the Spectralink 8400 product specifications it supports:

* WPA-Personal
* WPA2-Personal
* WPA2-Enterprise (EAP-FAST or PEAP MSCHAPv2)
* Opportunistic Key Caching (OKC)
* Cisco Client Key Management (CCKM)

According to Polycom's support site Spectralink phones require U-APSD (Unscheduled Automatic Power Save Delivery) to be enabled and it isn't by default with Aerohive. The U-APSD settings can be found in the WMM area of the SSID settings:

Spectralink phones also require that WPA only uses TKIP encryption and WPA2 only uses CCMP encryption (as per the standard).
Photo of Matthew Gast

Matthew Gast

  • 284 Posts
  • 63 Reply Likes
You have almost certainly figured this out by now, so I leave it as a comment for anybody else coming across the thread.  The Aerohive AutoWPA modes support both TKIP and CCMP, so you'll want to choose either WPA ("TKIP") or WPA2 ("CCMP") on the SSID you're connecting phones to.  Unless you have a good reason, choose WPA2!
Photo of robert korn

robert korn

  • 13 Posts
  • 1 Reply Like
Both phone makes are now connecting.

Setup the SSID with:
Auto - (WPA - WPA2) - PSK
Auto- TKIP or CCMP (AES)
Enable WMM
Enable UAPSD
Disable 802.11n high throughput capabilities to support incompatible.....

The SSID is setup to assign the existing Voice Vlan when user associates.

Thanks All.
I hope to report back with the results of our little test.

Photo of Shawn Fisher

Shawn Fisher

  • 1 Post
  • 0 Reply Likes

I have some difficulty with getting my spectralink to work. What information are you getting on you site survey on your phone? Mine doesn't look anything close to what polycom wants, but I have followed you recommendations on the SSID setup and no luck. Any information would be awesome, thanks.
Photo of Brad Hart

Brad Hart

  • 1 Post
  • 0 Reply Likes
    I thought providing the settings I used would be useful since this article helped solve my problem.  I also authenticate using radius servers, etc... I have the SpectraLink 8440 also.

Setup the SSID with: 
WPA2-(WPA2 Enterprise) - 802.1x
Enable WMM
    - Under WMM, enable Unscheduled Automatic Power Save Delivery (UAPSD)
    - This setting seemed to be the culprit.  Without it my phone would always say (No AP's Found)  
       yet under the diagnostics, I could see my AP's BSSID and the channel being advertised.

***The following setting did not matter for me***
Disable 802.11n high throughput capabilities to support incompatible

8440 Phone
DHCP Enabled
AC Required - NO
Enter SSID
Security - WPA2- Enterprise
Under WPA2 - Enterprise Setting, do the following
    -Fast Roaming OKC
    -User ID - (Your ID)
    - Password (Your Password)
    -EAP - Method:  PEAPv0/MSCHAPv2
    -InBand Provisioning: Unauthenticated

** I only used the 5ghz band so I turned off 2.4 under radio but it was not necessary
Regulatory Domain 01

Photo of Riogrande Bounces

Riogrande Bounces

  • 2 Posts
  • 0 Reply Likes
In our environment the options that made the difference were the other 2 options under Enable WMM. Which I believe is Voice and Video, once we checked those, the phone just worked.I need to test with other devices we use on the network now like mobile scanners etc to make sure nothing else breaks with those settings on.
Photo of Riogrande Bounces

Riogrande Bounces

  • 2 Posts
  • 0 Reply Likes
Also the symbol " in our production passphrase was breaking it, we had to create a new SSID without that symbol.