Client roams to far away AP instead of closest one

  • 2
  • Question
  • Updated 1 year ago
Hello, i have a few clients which are positioned almost 3m directly under a AP, but still roam away to another AP further away which is on the edge of a working signal. This causes signal issues. Client monitor shows a STA roam away to the far away AP and sometimes it comes back to the closest AP, then sticks for a few hours, then jumps to the far away AP. 

Does anyone have an idea what could be causing this? 
Photo of Sebastiaan Bosveld

Sebastiaan Bosveld

  • 32 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 2
Photo of Steve Netzel

Steve Netzel

  • 1 Post
  • 0 Reply Likes
I'm getting this, too. I have a classroom of 25 laptops and some seem to wander and I get no internet connection until I reboot the computer, then it seems to find the AP. Sometimes after 5 minutes or so it will do it on its own but with kids testing now, I can't very well sit around and wait. I will be interested in hearing about a resolution. Currently have a ticket open but they say the system "looks good"......
Photo of Hans

Hans

  • 68 Posts
  • 8 Reply Likes
Steve, start with trying to update the Wireless nic drivers (and chipset).
Photo of Hans

Hans

  • 68 Posts
  • 8 Reply Likes
Hello Sebastiaan
Important to know is that it is always the client that initiates the roaming procedure. Sticky roaming can be caused by a bad (or less good) design. Every client has it's wireless chipset and every chipset has it's own procedure for roaming tressholds. Mostly the roaming depends on the RSSI treshold of a client. So, if for example, a WiFi chipset of a client has a roaming tresshold at -75dBm and the client has a RSSI of -72dBm while standing under another AP much closer, the client will not roam to the closer AP with a better signal (and a better datarate). What you can do:
- disable the lower data rates (1, 2, 5.5 and 11 Mbps)
- if possible lower the power of the radios (15dB for 2.4Ghz and 17dB for 5Ghz is a good value)
- if there are a few clients with roaming issues, be sure they have an updated chipset driver and updated drivers for the wireless cards
If the problems still ocure, a professionel site survey can give you insight in the wireless environment. Based on this survey the config can be adjust or advice can be given.
Photo of Dawn

Dawn

  • 4 Posts
  • 0 Reply Likes
There's such a big list of things that could be causing this.  If it is just a few clients maybe it's a driver issue otherwise start with:
-going lower on the power to 11 db for 2.4 and 13db for 5ghz.  
-perhaps you have too many of the 2.4 radios turned on?
-do you have load balancing on the APs enabled?
-A site survey is always a good idea.
Photo of Dawn

Dawn

  • 4 Posts
  • 0 Reply Likes
 Have you tried client monitor?
One more random thought.  Some clients still don't play nicely with 144.  
(Edited)
Photo of Rob Pritchard

Rob Pritchard

  • 86 Posts
  • 8 Reply Likes
Sebastiaan,

Are you a school or a business?  I work for a school district and we have an AP in every classroom, so I've lowered the power of my 5Ghz radios to 10 (12 if it's a bigger than standard sized classroom) and disabled the 2.4Ghz on every other AP.  My Aerohive support engineer recommended having a difference of at least 7 in the power level of the 5Ghz and 2.4Ghz radios (where both are enabled on a single AP) so that the clients steer towards 5Ghz.  Do you know if these clients are connecting on 2.4Ghz or 5Ghz?  If they're connecting on 2.4Ghz but have the ability to connect at 5Ghz, then I would recommend modifying your settings so that your clients connect at 5Ghz instead of 2.4Ghz since it's faster and doesn't have the range of 2.4Ghz so maybe the clients won't roam as much, if at all.  And I definitely agree with what Hans recommended - disable the lower data rates and definitely make sure the drivers are up-to-date, especially if the drivers are two years old or older.
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
In the 5 GHz radio profile did you disable the DFS channels?  As a rule of thumb I do and therefore just have the eight 20 MHz channels - 36, 40, 44, 48, 149, 153, 157 and 161.  A number of wireless devices do not support the DFS channels so will not associate to a radio configured for a DFS channel.
Photo of Sebastiaan Bosveld

Sebastiaan Bosveld

  • 32 Posts
  • 0 Reply Likes
Hello Crowdie, i do NOT have the 5Ghz band enabled on this SSID. It's 2.4Ghz only. I tested this yesterday, the devices connecting sometimes have trouble connecting to 5Ghz, that's why it's 2.4 only. 
Photo of Hans

Hans

  • 68 Posts
  • 8 Reply Likes
Sebastiaan
As Crowdie mentioned, some clients have problems with DFS channels. In Europe we need the DFS channels to create the 20 channels (so we can use 40MHz channels). Without DFS we only have 4 channels from UNII1. In the VS they can also use UNII3 and have more (9 I believe) channels without DFS. So check DFS settings.
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
Hello Sebastiaan.  I was referring to when you originally had the 5 GHz radios enabled.  In some industrial environments 5 GHz is just not possible unless you want to spend a large amount of money.
Photo of Sebastiaan Bosveld

Sebastiaan Bosveld

  • 32 Posts
  • 0 Reply Likes
Correct. We have some manufacturer equipment that refuses to connect to 5Ghz. Sometimes it does and causes nothing but pain.
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
If you have an Android smartphone and/or tablet I would recommend the Aruba Utilities application for roaming analysis.  Associate the Android smartphone and/or tablet to the wireless network and run the application.  When the application opens click on the "SHOW SCAN RESULTS" button at the bottom.  In the bottom area of the screen you will see information on the radio you are currently associated to and you will also see when it roams.

As previously mentioned each wireless card manufacturer has a "secret sauce" as to when to roam (commonly using SNR, retry rates, etc.) but this should give you some idea of where devices are looking to roam.
(Edited)
Photo of Sebastiaan Bosveld

Sebastiaan Bosveld

  • 32 Posts
  • 0 Reply Likes
I have been looking at all settings, but to no avail. What i do notice is that it's only 2.4Ghz client that connect to the far away AP. The 5Ghz clients on other SSIDs connect just fine to this AP. 
Photo of Hans

Hans

  • 48 Posts
  • 7 Reply Likes
2.4Ghz has less problems with attenuation then the 5GHz frequentie. It 'travels' further.
Photo of Sebastiaan Bosveld

Sebastiaan Bosveld

  • 32 Posts
  • 0 Reply Likes
To test this, i have turned the power down to 12 on the "further away" AP. Still the clients connect to that AP. Now testing with another firmware to see if that behaves differently.
Photo of Sebastiaan Bosveld

Sebastiaan Bosveld

  • 32 Posts
  • 0 Reply Likes
I have downgraded the firmware on both APs and now i see the client trying to connect to the right AP, but it shows this in the clients monitor: 

25-04-2017 08:18:28 AM  80000BEBE353  D854A2040415  AP104        BASIC   (115)Rx auth <open> (frame 1, rssi -48dB)25-04-2017 08:18:28 AM  80000BEBE353  D854A2040415  AP104        BASIC   (116)Tx auth <open> (frame 2, status 0, pwr 13dBm)
25-04-2017 08:18:29 AM  80000BEBE353  D854A2040415  AP104        BASIC   (117)Rx auth <open> (frame 1, rssi -36dB)
25-04-2017 08:18:29 AM  80000BEBE353  D854A2040415  AP104        BASIC   (118)Tx auth <open> (frame 2, status 0, pwr 13dBm)
25-04-2017 08:18:29 AM  80000BEBE353  D854A2040415  AP104        BASIC   (122)Rx auth <open> (frame 1, rssi -48dB)
25-04-2017 08:18:29 AM  80000BEBE353  D854A2040415  AP104        BASIC   (123)Tx auth <open> (frame 2, status 0, pwr 13dBm)
25-04-2017 08:18:30 AM  80000BEBE353  D854A2040415  AP104        BASIC   (124)Rx auth <open> (frame 1, rssi -47dB)
25-04-2017 08:18:30 AM  80000BEBE353  D854A2040415  AP104        BASIC   (125)Tx auth <open> (frame 2, status 0, pwr 13dBm)
25-04-2017 08:18:30 AM  80000BEBE353  D854A2040415  AP104        BASIC   (132)Rx auth <open> (frame 1, rssi -39dB)
25-04-2017 08:18:30 AM  80000BEBE353  D854A2040415  AP104        BASIC   (133)Tx auth <open> (frame 2, status 0, pwr 13dBm)
25-04-2017 08:18:31 AM  80000BEBE353  D854A2040415  AP104        BASIC   (134)Rx auth <open> (frame 1, rssi -39dB)
25-04-2017 08:18:31 AM  80000BEBE353  D854A2040415  AP104        BASIC   (135)Tx auth <open> (frame 2, status 0, pwr 13dBm)
25-04-2017 08:18:31 AM  80000BEBE353  D854A2040415  AP104        BASIC   (142)Rx auth <open> (frame 1, rssi -48dB)
25-04-2017 08:18:31 AM  80000BEBE353  D854A2040415  AP104        BASIC   (143)Tx auth <open> (frame 2, status 0, pwr 13dBm)
25-04-2017 08:18:32 AM  80000BEBE353  D854A2040415  AP104        BASIC   (144)Rx auth <open> (frame 1, rssi -39dB)
25-04-2017 08:18:32 AM  80000BEBE353  D854A2040415  AP104        BASIC   (145)Tx auth <open> (frame 2, status 0, pwr 13dBm)
25-04-2017 08:18:32 AM  80000BEBE353  D854A2040415  AP104        BASIC   (152)Rx auth <open> (frame 1, rssi -47dB)
25-04-2017 08:18:32 AM  80000BEBE353  D854A2040415  AP104        BASIC   (153)Tx auth <open> (frame 2, status 0, pwr 13dBm)
25-04-2017 08:18:33 AM  80000BEBE353  D854A2040415  AP104        BASIC   (154)Rx auth <open> (frame 1, rssi -36dB)
25-04-2017 08:18:33 AM  80000BEBE353  D854A2040415  AP104        BASIC   (155)Tx auth <open> (frame 2, status 0, pwr 13dBm)

It doesn't seem to want to connect.. 
Photo of Crowdie

Crowdie, Champ

  • 904 Posts
  • 261 Reply Likes
If the wireless NIC is manufactured by Intel then I recommend the Intel Driver Update Utility.  It will update your Intel drivers.

Warning:  If you run the Intel Driver Update Utility on a laptop DO NOT update the graphics driver.  Laptop graphics drivers are customised for the laptop's unique display.
Photo of Sebastiaan Bosveld

Sebastiaan Bosveld

  • 32 Posts
  • 0 Reply Likes
It's impossible to do this. It's manufacturer client and i can't update the NIC driver. We have another bunch that work correctly on other APs, but they also don't connect to this one. 
Photo of Crowdie

Crowdie, Champ

  • 904 Posts
  • 261 Reply Likes
Is the wireless device that will not connect a Desktop PC/laptop?  If so, can you advise the make and model of the wireless NIC?
Photo of Crowdie

Crowdie, Champ

  • 904 Posts
  • 261 Reply Likes
What is the authentication method (802.1X, Private PSK, PSK or Open) for the 2.4 GHz SSID?
Photo of Sebastiaan Bosveld

Sebastiaan Bosveld

  • 32 Posts
  • 0 Reply Likes
Private PSK. The devices connecting 2 sorts. One is a customized Panasonic Toughbook with what i believe is a Marvell Chipset. The other is totally custom and i have no idea what kind of chip is in there. 
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
There are a few settings that I recommend you disable:
  • Dynamic Airtime Scheduling (Airtime Fairness): Configuration -> Network Policies -> [Network Policy] -> Additional Settings -> QoS Settings -> Dynamic Airtime Scheduling.
  • Frame Burst: Configuration -> Radio Profiles -> [2.4 and 5 GHz Radio Profile] -> Radio Settings -> Enable Frame Burst 
  • MU-MIMO:  Configuration -> Radio Profiles -> [5 GHz Radio Profile] -> Radio Settings -> Enable MU-MIMO (AP250/AP245X/AP550)
  • Dynamic Frequency Selection: Configuration -> Radio Profiles -> [5 GHz Radio Profile] -> Channel and Power -> Enable DFS (Dynamic Frequency Selection) channels
  • VHT: Configuration -> Radio Profiles -> [2.4 GHz Radio Profile] -> Radio Settings -> Enable VHT (Very High Throughput) for the 2.4 GHz band (Applies only to 802.11ac platforms except the AP370 and AP390)
(Edited)
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
The two access points are too close so the wireless driver is bouncing between the two.  Could one of the access points be moved further away?  When I need a very dense access point deployment I place the access points in rooms rather than open plan areas so the walls naturally reduce the signal.

I am assuming that if you disable the 2.4 GHz radio on the access point closest to the other access points (i.e. not by the perimeter) you will create a coverage hole.
(Edited)
Photo of Sebastiaan Bosveld

Sebastiaan Bosveld

  • 32 Posts
  • 0 Reply Likes
I have to look into that because then i risk placing it too close to another and create the same problem there. For now i have excluded the far AP as neighbour, deauthed the clients and they bounced back to the right AP. They have been connected to it for an hour now, so it looks OK. Although i'm not sure what the effects are of excluding an AP as a neighbour. 
Photo of Sebastiaan Bosveld

Sebastiaan Bosveld

  • 32 Posts
  • 0 Reply Likes
Too bad. Even though i excluded the far AP as neighbour, it still roams over to that AP. I Guess my only option remains to reposition the APs in our workshop and possibly do a site survey. 
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
The neighbour option only applies to layer three roams.  Layer three roams occur when different subnets are in play.  If there is only a single subnet, as I suspect applies to you, the neighbour option has no effect.
(Edited)
Photo of Sebastiaan Bosveld

Sebastiaan Bosveld

  • 32 Posts
  • 0 Reply Likes
Correct. So maybe reorganizing and placing the APs in different positions solves a lot more. 
Photo of Sebastiaan Bosveld

Sebastiaan Bosveld

  • 32 Posts
  • 0 Reply Likes
After help from a supplier we have found the cause to this problem. The closest by AP was suffering from major interference on channel 6 and 11 on the 2.4 band. When we set the AP to fixed channel 1, all problems resolved itself.
Photo of Hunter Hu

Hunter Hu

  • 24 Posts
  • 1 Reply Like
Can you share how to find it for this reason?
thanks.
Photo of Bill W.

Bill W.

  • 208 Posts
  • 31 Reply Likes
You would use a spectrum analyzer and/or other Wi-Fi scanner. There is a spectrum analyzer built-in to HM. Or you could use something like MetaGeek Chanalyzer (paid and requires hardware) or Acrylic Wi-Fi Home (free).