Client roaming

  • 1
  • Question
  • Updated 4 years ago
  • Answered

Hi

We have about 185 AP's (AP121) in our network. Users get a VLAN assigned (802.1x) according to their group membership (VLAN's are available on all AP's), so they get the same VLAN where ever they connect.

All AP's are in the same management VLAN and in the same Hive. We use HiveManager On line.

Today, while scanning with InSSider (following up on some complaints we received) I noticed that my laptop remained connected to the first AP I was connected to entering the building. I took over 5-6 minutes before I was connected to the AP with the "best" signal quality.

Are there any settings (AP, Hive manager) I can adjust to speed up the roaming process?

Thanks in advance!


Photo of Kevin Baert

Kevin Baert

  • 28 Posts
  • 1 Reply Like

Posted 4 years ago

  • 1
Photo of Hans Matthé

Hans Matthé

  • 131 Posts
  • 28 Reply Likes

Hi Kevin

Do you have tested with different clients? Know that it is mostly the client that take the roaming decissions, not the ap.

Photo of Kevin Baert

Kevin Baert

  • 28 Posts
  • 1 Reply Like

Hi Hans


Thanks for the quick reply.

Yes, we received this complaint from different users, using different clients and OS'es (ios, windows, android). Some of them where standing directly under an AP and where still connected to their "previous" AP, it sometimes took minutes before they where connected with the new AP.

I'm not at all familiar with these settings but I have read some info about the possibility of layer2/3 roaming and a caching option within aerohive ...


thanks!

Photo of Hans Matthé

Hans Matthé

  • 131 Posts
  • 28 Reply Likes

Hi Kevin

An other cause of sticky roaming is the use of load balancing (clients sometimes won't reassociate at AP's that are crowdy and load balancing is configured).  Is this configured at your network?

Photo of Kevin Baert

Kevin Baert

  • 28 Posts
  • 1 Reply Like

Hi Hans

no, that option's not configured.



Photo of John Fabry

John Fabry

  • 28 Posts
  • 8 Reply Likes
We have had some success with lowering power settings and increasing the minimum speed to 18MB. on the APs.  We did this mainly for the sticky MAC clients.
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
As others have implied, it sounds like you may have the power levels set too high and/or are allowing low data rates, allowing the sticky clients to hang on to their original AP even when there is a "better" one nearby. I'll let the other experts here offer specific advice, John Fabry is on the right track.
Photo of Kevin Baert

Kevin Baert

  • 28 Posts
  • 1 Reply Like

Thanks Mike and John!

John would it be possible to point me in the right direction?

Am I correct that radio rates are set on the SSID?

How do I configure this correctly?


Thanks!


Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
Another option is the "Weak SNR Probe Response Suppression" functionality in the radio profile.  Basically it tells an access point to not respond to a wireless client whose SNR (the usable amount of signal) is less than xx dB.



The threshold you should set to really up to your wireless network but 25 dB is considered a good SNR so 15 to 20 dB could be suitable.
Photo of J. Goodnough

J. Goodnough, Champ

  • 266 Posts
  • 32 Reply Likes
In places on my network I've seen with poor roaming performance, the problem tended to be too many strong signals - reducing signal strength or even removing an AP improved roaming performance. Also note that Aerohive's automatic radio power setting will only reduce the radio power a certain amount from the radio-profile-configured max radio power, so in some situations it cannot be relied on to reduce signal strength enough.
Photo of John Fabry

John Fabry

  • 28 Posts
  • 8 Reply Likes
SSID - optional settings - Radio and Rates
We set the 2.4 and 5 ranges to 12MB.

Then we created a radio profile to set the power and channel settings. Create the profile and under the advanced settings (we) set MAX Transmit Power to 10. And channel setting t oadjust channels every 10 minutes.
Photo of Kevin Baert

Kevin Baert

  • 28 Posts
  • 1 Reply Like

Thanks John!

Will try these options and will report back!

Photo of Kevin Baert

Kevin Baert

  • 28 Posts
  • 1 Reply Like

Hi


I adjusted the power and channel settings (new profile) and tested this on one location.

Seems to work fine!

Will test this further and will apply the radio and rates suolution when necessary.

thank you all!