Captive Portal pages do not display correctly

  • 1
  • Question
  • Updated 5 years ago
  • Answered


This is the AUP page from an AP121 with 6.0r2b - just got this demo AP today. Upgraded to latest firmware. The success page also displays incorrectly - just a check mark and no text. Also very slow, took 30 seconds after clicking on Submit.
Same issues on 2 different laptops and 3 different browsers (Chrome, Firefox and IE). Displayed page does not look at all like preview. ???
Photo of Gerry Aquino

Gerry Aquino

  • 2 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
You can remove the captive portal pages from your access points and reload them.

To remove the captive portal pages:

Monitor -> All Devices -> Aerohive APs -> [Select all the APs with the captive portal] -> Update... -> Remove Captive Web Page Directory

Now to upload the captive portal pages again:

Monitor -> All Devices -> Aerohive APs -> [Select all the APs with the captive portal] -> Update... -> Upload and Activate Configuration

Ensure the "Upload and activate captive web portal pages and server key" is enabled (the other three options can be enabled or disabled as you feel appropriate) and then upload to the access points.

Note: If the upload type is "Complete Upload" then the access point will reboot after the upload. If you don't want this then sure the upload type is "Auto".
Photo of Gerry Aquino

Gerry Aquino

  • 2 Posts
  • 0 Reply Likes
Thanks for the help, but unfortunately the result is the same. I configured this following the youtube video, and while the portal action works, it the pages still aren't right.

also the rate limiting feature does not work either



I get the same speed ,10.13 Mbps, from the Guest-Wifi that I get from the Default SSID
Photo of Brian Ambler

Brian Ambler

  • 245 Posts
  • 126 Reply Likes
Hi Gerry,

Regarding your comment about rate limiting not working, please be aware that rate limiting will only take effect when there is contention for the medium. More information on rate limiting can be found in this post.

Hope this helps