Can't manually configure channel

  • 1
  • Question
  • Updated 8 months ago
  • (Edited)
Hi guys,

I have an old Ap121 I am using at home. It was linked to HM account but that has expired and now I can't add it to another account.

but anyway I have configured it using CLI and all is well, except I cannot explicitly set the channel of operation, I have used an android app to tell me the best channels to use for 2.4ghz and 5ghz and I would also like to use double channel bandwidth but both commands are throwing me errors

My config:
radio profile Wifi1
radio profile Wifi1 band-steering enable
radio profile Wifi1 band-steering mode prefer-5g
security-object Wifi1
security-object Wifi1 security protocol-suite wpa2-aes-psk ascii-key hidden
ssid myssid
ssid myssid security-object Wifi1
interface wifi0 radio profile Wifi1
interface wifi0 radio power 20
interface wifi0 radio antenna diversity
interface wifi1 radio power 20
interface wifi1 radio antenna diversity
interface wifi0 ssid myssid
interface wifi1 ssid myssid
no capwap client enable

AH-cfde40# interface wifi1 radio channel 14
the desired channel (14) is inconsistent with current phymode or primary channel offset!
ERROR: Invalid parameter(s)
AH-cfde40#

I have tried changing all the values below as suggested by the error but none have allowed me to set the channel!

AH-cfde40#radio profile Wifi1 phymode
    11a     Set the physical mode to 11a (Default: 11b/g)
    11b/g   Set the physical mode to 11b/g (Default: 11b/g)
    11na    Set the physical mode to 11na (Default: 11b/g)
    11ng    Set the physical mode to 11ng (Default: 11b/g)


AH-cfde40#radio profile Wifi1 primary-channel-offset
    0      Set primary channel offset to 0 (Default: auto)
    1      Set primary channel offset to 1 (Default: auto)
    2      Set primary channel offset to 2 (Default: auto)
    3      Set primary channel offset to 3 (Default: auto)
    auto   Set primary channel offset to auto (Default: auto)
Photo of ryan

ryan

  • 10 Posts
  • 0 Reply Likes

Posted 8 months ago

  • 1
Photo of Gary Smith

Gary Smith, Official Rep

  • 299 Posts
  • 61 Reply Likes
Hi Ryan,

Channel 14 is not a valid channel for 2.4GHz or 5GHz radios. You are trying to configure this channel for 5GHz.

Please run this command;
"show acsp channel-info"

It will give you a list of the available channels that you can use on both radios.

Kind Regards,
Gary Smith
Photo of ryan

ryan

  • 10 Posts
  • 0 Reply Likes
yes thank you that has worked now I have used 13 for 24.ghz and 48 for 5ghz. I still can't configure a 40mhz channel width but not too worried about that:

AH-cfde40#radio profile Wifi1 channel-width 40
Desired channel width (40) is inconsistent with current phymode or primary channel offset