Bridge 802.1q question.

  • 1
  • Question
  • Updated 5 months ago
Hello everyone. I want to make sure i understand our setup correctly. The AP which is connected to the network switch should be in which mode? Bridge-access, backhaul or bridge-802.1q? The AP on the other end should also be in which one of those modes to ensure it communicates efficiently and correctly? We have 3 P2P AP's (1130 models) setup like this and i want to ensure i have them setup correctly and they are functioning properly. Thank you
Photo of sam lujan

sam lujan

  • 10 Posts
  • 0 Reply Likes

Posted 5 months ago

  • 1
Photo of Carsten Buchenau

Carsten Buchenau, Champ

  • 356 Posts
  • 117 Reply Likes
The Ethernet interface of the AP facing your network access should be in Backhaul mode (read: Uplink). The Ethernet interface of the AP "on the other side" should be either in bridge-access or bridge-802.1q:
- bridge access, if anything connected behind is inside the same (untagged) vlan
- bridge-802.1q, if you need tagged vlans as well (another AP, a telephone, ...)

Think of the Mesh link as a Client-Server link: You want to "bridge the clients through to the server side via a backhaul link", simply speaking.

What it does: All MAC addresses on Wifi Access interfaces (= bridge mode!) and Ethernet interfaces in bridge mode are advertised (= bridged) through the backhaul link, so that the upstream switch learns all MAC addresses that are behind this switch port, and thus traffic can be sent accordingly. This includes all MAC addresses that the AP learns on the Ethernet interface in bridge mode. Therefore it is very important to NOT connect your Ethernet interfaces in bridge-mode to the upstream network, because that would advertise ALL MAC addresses learned from the Switch on the bridge port to be advertised on the backhaul port - you you have a loop.

Hope this makes it clearer?
Photo of sam lujan

sam lujan

  • 10 Posts
  • 0 Reply Likes
Thank you carsten. I have another issue you may help resolve. Our AP which points from our concession stand to the AP over at the gym (which is connected directly to the network switch) stops responding when i enable the 802.1Q option. In hivemanager it stays on rebooting and never recovers from that. So i have to reset the AP and reconfigure to start all over. Also, when i do enable the 802.1Q option, it takes down the two other AP's which are pointing to the Gym where the other AP's reside which are connected physically to the network. The 3 AP's at the gym are all in backhaul mode and the three on the receiving end are in bridge-access mode. They are all functioning except, the concession stand AP is communicating but, we had to give it a static IP and the others are running DHCP. Is this the ideal setup, we want to run 802.1Q on the receiving end AP's but dont want to take anyone down. Hope i was clear and made sense.
Photo of Carsten Buchenau

Carsten Buchenau, Champ

  • 356 Posts
  • 117 Reply Likes
I am not sure... can you add a network diagram, including all wired and wireless mesh links? A scanned hand-drawing would be just fine ;-)
Photo of sam lujan

sam lujan

  • 10 Posts
  • 0 Reply Likes
Awesome, I will see what we have, thanx again...
Photo of sam lujan

sam lujan

  • 10 Posts
  • 0 Reply Likes
Photo of sam lujan

sam lujan

  • 10 Posts
  • 0 Reply Likes
The 3 AP's at the gym are connected to the network switch and then go out to the other 3, concession stand, guard shed and the superintendents house. The sup2gym AP is the only one in 802 mode, the other two going to the gym are bridge-access and of course the 3 at the gym are in backhaul mode. If i change the bridging options for any of the ones going to the gym, the other two go down.... 
Photo of Carsten Buchenau

Carsten Buchenau, Champ

  • 356 Posts
  • 117 Reply Likes
Hmmm... so you have anything connected to the Ethernet port of the 3 distant APs?

The 3 MESH links are really p2p, or multi-link? How is this configured? A dedicated SSID for each link, on 5GHz radios only, radios configured to be in Mesh only (no client connections), and a dedicated channel per link? My suspicion is that somehow you create a loop....

My advise:
- Disconnect anything from the Ethernet ports of the 3 remote-APs.
- Ensure that the MESH links are configured properly: 5GHz, dedicated radio (no client connections allowed), dedicated channel per link (to ensure you have 3 P2P links, not 1 AP connecting to 2 or 3 remote APs). Ideally even configure a dedicated SSID for each link.
- Now configure the 3 Ethernet ports of the 3 remote-APs as you want them - still all working?
- Now connect whatever you need to connect, start with ONE AP only. All working?

Hope this helps...
Photo of sam lujan

sam lujan

  • 10 Posts
  • 0 Reply Likes
The only way the 3 AP’s connect to the gym is wirelessly utilizing 5GHz. The guard shed, the superintendents house and the concession stand. When you ask if anything is connected to the ethernet ports of the remote AP’s, do you mean if something is connected to the port of the AP? The AP at the superintendents house is used for his connectivity for internet. The guard shed AP has the workstation used for the surveillance system and the kiosk used to issue visitor passes. The concession stand AP is connected to a switch inside so that we can view the security camera. The con2gym AP has 2.4 radio is up and set to omni and the 5 radio is up and set to directional mode. The guard shed has 2.4 radio down and has the 5 radio up and set to directional mode. The superintendents house has the 2.4 up and set to omni and the 5 radio up and set to directional. Also, the con2gym is the only one which has a static IP set because it should have DHCP but for some reason it doesnt pick up an address.