iTunes Home Sharing

  • 1
  • Question
  • Updated 5 years ago
  • Answered
I have a wireless laptop and a wired Apple TV hooked up to a BR200-WP/AP121 combo. How can I get iTunes home sharing to work? AirPlay is working great. As soon as I take the Apple TV to a wireless connection, the home sharing works perfect. It does not when the Apple TV is hard wired. Any thoughts?
Photo of Bradley Chambers

Bradley Chambers, Champ

  • 302 Posts
  • 53 Reply Likes

Posted 6 years ago

  • 1
Photo of Bradley Chambers

Bradley Chambers, Champ

  • 302 Posts
  • 53 Reply Likes
This ended up being a VLAN issue
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
Hi Bradley,
I'm glad you were able to resolve this on your own, somehow it didn't leap out to me that this had been posted and unanswered for 5 days.

For those who come along afterwards and see this thread, would you mind sharing your troubleshooting process so others can see how you made that determination and how you remedied the situation?
Photo of Bradley Chambers

Bradley Chambers, Champ

  • 302 Posts
  • 53 Reply Likes
From what I can tell, iTunes Home Sharing (which is different from AirPlay) cannot cross a VLAN. The only option is to put the devices to share you need on the same VLAN.
Photo of Bradley Chambers

Bradley Chambers, Champ

  • 302 Posts
  • 53 Reply Likes
Alright it looks like I might have found a bug. I've got my wired and wifi onto same VLAN and still seeing this issue. I'm on 5.1r4.

Am I missing something? Here is the tech documentation on home sharing (again this is diff than bonjour from what I gather): http://support.apple.com/kb/TS2972?vi...
Photo of Chris Henderson

Chris Henderson

  • 1 Post
  • 0 Reply Likes
I had a similar problem to this with an Apple TV connected to the eth1 port on an AP330. If the Apple TV was connected to the AP330 wirelessly, everything worked fine but as soon as I attached it to the wired eth1 port all the Bonjour services would start by being available then they would disappear after about 30 seconds. My local Aerohive support guy suggested that I try pinging the Apple TV every 15 secs or so to see if this made a difference. This worked but it has highlighted a "bug" which apparently is currently being worked on at Aerohive.

I hope this helps.