BR100: How do I forward HTTP, FTP, and RDP ports all to 10.10.106.11?

  • 1
  • Question
  • Updated 4 years ago
  • Answered
Hi, I'm having trouble understanding the configuration for port forwarding. I found the settings. I simply want to forward HTTP, FTP, and RDP ports all to 10.10.106.11 but can't figure out how. Anyone can provide insight on what goes in the boxes. Specifically what is the destination port vs internal host port.

Note: This topic was created from a reply on the How do I set up BR100 Port Forwarding? topic.
Photo of Pritesh Patel

Pritesh Patel

  • 4 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Brian Ambler

Brian Ambler

  • 245 Posts
  • 126 Reply Likes
Hi Pritesh,

I wrote up a guide a while back that (I believe) covers exactly what you are asking for in you post, which you can find here. If this does not get you up and running just let me know and I can try and explain things in a bit more detail.

Hope this helps
Photo of Pritesh Patel

Pritesh Patel

  • 4 Posts
  • 0 Reply Likes
Thanks for the link. I saw that after I posted and skimmed through it but needed to thoroughly understand it before I ask again.

Let me just say I'm new to this. Only reason I have this router is because my old one was dropping wireless after so many minutes and I needed a replacement. My brother-in-law gave this to me free so am using it. Although I'm no novice, this router is just way to too complex. Despite that, I've figured out everything except the port forwarding part.

So after reading your tutorial, if I want to forward ports 21 and 3389 to 10.10.106.11, is below correct?

destination port: 21
Local Host IP address: 11
Internal host port number: 21
traffic: any


destination port: 3389
Local Host IP address: 11
Internal host port number: 3389
traffic: any
my gateway is 10.10.106.254.

And I couldn't figure out how to forward port 80 (for http web server) cause I get message saying: "80 has already been used in the destination port number". How do I enable web server?

Thanks in advance.
Photo of Brian Ambler

Brian Ambler

  • 245 Posts
  • 126 Reply Likes
Hi Pritesh,

You are pretty close, but you would want to use n-1 in the excluded address pool for the address to which you wish to forward the defined ports. So in your case (assuming that your have excluded at least the first 10 addresses), if you want to forward ports 21 and 3389 to 10.10.106.11 you would choose "10" from the Local Host IP Address drop down box. This is due to the first IP address being reserved for the router (if so configured), so the logical mapping of the first available IP address in the excluded list is actually the second actual address (x.x.x.2). However, if you have reserved the last IP address for the router's address then the first available address is indeed x.x.x.1.

It may be easier to visualize these mappings, in which case just click the "IP Address Mapping" button and you can pick the desired position from the drop down box to see it's actual mapping (if reserving the first IP address in the subnet for the router).


However, what may actually be easier is to click the "Position" drop own box and choose "Branch" which will list all of the logical positions next to the actual addresses:


So, to wrap things up, here is an example using your definitions (Note that I have excluded a number of IP addresses at the start of the pool, though you do not need to exclude 99, just at least 10)


Regarding your question on how to forward port 80, unfortunately this is one of the Aerohive reserved ports as the Branch Router hosts its own web server running on ports 80 and 443. Because of this you will get the admittedly rather cryptic message of "80 has already been used in the destination port number." This is the system trying to tell you that port 80 is already reserved by the router, so another port must be used (for a full list of reserved ports, click the "View Aerohive Ports" button). To get around this limitation, as I used in the above screencap, simply forward a unique destination port (any port not on the reserved list can be used).

Hope this helps











Photo of Pritesh Patel

Pritesh Patel

  • 4 Posts
  • 0 Reply Likes
Brian, thanks for the guide. I followed it and got everything working.

So before I tried your instructions, my brother in law told me I had to set network firewall policies. So I was trying to configure that for port forwarding. However that didn't work and the settings are still in place. Can I delete those firewall setting?

To answer my own question above - yes. I deleted the firewall rules and it still works.

But I have another questions. When I connect to my http server with the port I assigned it works fine. Of course, when you leave the port out from URL, it assumes port 80 and fails to connect.

I get a message saying Error 502. Unable to resolve address for url....

Question is: is this message coming from my server or from aerohive? If from my server, I can investigate and try to display a custom message.

Thanks.
(Edited)
Photo of Brian Ambler

Brian Ambler

  • 245 Posts
  • 126 Reply Likes
Hi Pritesh,

My apologies for the delay in my response, I see that you did address your first question on your own. Regarding your follow up question, I am no expert on HTTP error codes, but I assume that this is coming from the server based on the syntax.

http://en.wikipedia.org/wiki/List_of_HTTP_status_codes#5xx_Server_Error

502 Bad Gateway
The server was acting as a gateway or proxy and received an invalid response from the upstream server
Photo of Brian Ambler

Brian Ambler

  • 245 Posts
  • 126 Reply Likes
Hi Pritesh,

My apologies for the delay in my response, I see that you did address your first question on your own. Regarding your follow up question, I am no expert on HTTP error codes, but I assume that this is coming from the server based on the syntax.

http://en.wikipedia.org/wiki/List_of_HTTP_status_codes#5xx_Server_Error

502 Bad Gateway
The server was acting as a gateway or proxy and received an invalid response from the upstream server