Bonjour Gateway VLAN problem

  • 2
  • Question
  • Updated 5 years ago
  • Answered
Dear community,

I'am trying to implement the free Aerohive Bonjour Gateway in our network environment to provide (only) Airprint funcitionality to our network, so that our iOS Devices can use our printers.

First of all a small topology of our network. We have several vlans which are involved in this scenario.

vlan 5: this is the vlan where all our printers resides.
vlan 3: this is the vlan where our endusers wired and wireless devices resides
vlan 10: this is the vlan where all IT-Service wired and wireless devices resides
vlan 114: this is the vlan where the MGT Interface of the Bonjoure Gateway resides

We use VMware vCenter 5.1 on our ESX host in combination with Cisco Nexus 1000V switches.

So I added 2 port-profiles to the Nexus 1000V. One port-profile is configured as a trunk port and one port profile is configured as an access port.

port-profile type vethernet vlan_114
vmware port-group Bonjoure
switchport mode access
switchport access vlan 114
no shutdown
max-ports 64
state enabled

port-profile type vethernet trunk_1
vmware port-group Aerohive_Trunk
switchport mode trunk
switchport trunk allowed vlan 1-10,101-103,105-108,110-117
no shutdown
max-ports 64
state enabled

The port-profile vethernet vlan_114 is connected to the first nic of the Bonjoure gateway and vlan 114 is heading straight to the firewall/wan.

Due to the fact that I can configure the gateway remotly via the cloud based HiveManager this seems to work fine!

The port-profile vethernet trunk_1 is connected to the second nic of the Bonjoure gateway and is configured as a trunk.

As you can see all needed vlans are included (3, 5 and 10).

I configured the Bonjoure Policy to scan only vlan 3, 5 and 10 for services.

But I don't see any services in my HiveManager.

Can anyone point out where I have messed up the configuration?

Thanks in advance.

Kind Regards
René
Photo of hlpinform

hlpinform

  • 10 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 2
Photo of hlpinform

hlpinform

  • 10 Posts
  • 0 Reply Likes
Okay, I fixed that by adding native vlan to the trunk_1 port profile:

port-profile type vethernet trunk_1
vmware port-group Aerohive_Trunk
switchport mode trunk
switchport trunk allowed vlan 1-10,101-103,105-108,110-117
switchport trunk native vlan 114
no shutdown
max-ports 64
state enabled

Than I connected both nics (nic1 and nic2) of the virtual machine to trunk_1 and removed port-profile vlan_114.

After a restart everything worked like a charm.
Photo of Mike Kouri

Mike Kouri, Official Rep

  • 1030 Posts
  • 271 Reply Likes
Thanks for updating us with how your resolved your problem, I'm sure others will appreciate it too!