Bonjour Gateway Services are not shared

  • 1
  • Question
  • Updated 5 years ago
  • Answered
Hi

I've installed Bonjour Gateway on our multiple vlan network. When I go into bonjour services I can see all the services but none are shared and all the services are on vlan 1. Can someone let me know what I need to do to share the services on the right vlan?

Simon
Photo of mccadmin@student.mountcarmel.tas.edu.au

Posted 5 years ago

  • 1
Photo of Rob

Rob

  • 42 Posts
  • 5 Reply Likes
Are you using the Bonjour gateway on the APs or are you using a VM? Which ever one your using make sure your trunking the proper vlans to the GW.
Photo of Emilio Maldonado

Emilio Maldonado

  • 37 Posts
  • 11 Reply Likes
Can you please revisit these steps:
- Add VLAN trunk support to your virtual switch in ESXi.
- Login to Vmware vsphere client, Configuration -> Networking -> Find the vswitch the virtual appliance will be connecting with, go to Properties, Network, Edit, then in the VLAN drop box select "All".
- Also when configuring the Virtual machine, for each of the ethernet devices select the destination network that was configured above as the VLAN trunk.

Look at this configuration video (minute 3:55) describing such steps
https://www.youtube.com/watch?v=Omp0V2...
Hi Emilio

I have already added the vlan trunk and assgned the vmnetwork to the bonjour gateway.

Attached are the images of the setup and the bonjour services showing that all are from vlan 1 and not shared.

Photo of Rob

Rob

  • 42 Posts
  • 5 Reply Likes
Looking at your screenshots you may have to add *._ipps._tcp. as a custom service if you want airprint to work across vlans.
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
In the Bonjour Gateway configuration which Bonjour services have you configured for advertisement?

In the standard HiveManager this is located at Configuration -> Advanced Configuration -> Common Objects -> Bonjour Gateway Settings. Unfortunately I have not used the free Bonjour Gateway but the GUI looks almost the same as the standard HiveManager GUI.

In the Bonjour Gateway Settings area you can:

* Specify the VLANs the Bonjour Gateway will scan for Bonjour Services

* Specify the Bonjour services, including custom services such as *._raop_tcp. for AirPlay, that the Bonjour Gateway should advertise.
Hi Crowdie

All our vlans are covered in the advertiement and airplay and airprint is all I have select

Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
I am probably going to put a downer on this but we couldn't get AirPlay working until the 5.1r5 firmware release and we had to add the *._raop_tcp. (Remote Audio Output Protocol) custom service. We have not been able to get AirPrint working via Safari in iOS to this day but we have been advised that this issue is being worked on. We can locate printers via Bonjour using third party applications under iOS.

That said, we could see the AppleTV and printer advertisements in the Bonjour Gateway.
Photo of Rob

Rob

  • 42 Posts
  • 5 Reply Likes
Airplay worked for us in 5.1.r4 after adding *._raop_tcp. I did have issues at first with vlans and noticed that the only way bonjour gateway would work is by adding each vlan instead of adding a range. Example VLANS: 4-7 doesn not work, VLANS: 4,5,6,7 works.
Photo of Crowdie

Crowdie, Champ

  • 972 Posts
  • 272 Reply Likes
We had a similar issue with one of the 4.x firmwares and the fault was tracked down to the IP Range object. If you created an IP range only the first IP in the range was valid. We found this when we used IP ranges in firewall rules for printer access and we could only access the printer with the first IP address in the range. We logged it with Aerohive Support as a fault and changed to using network objects (subnets) instead.