Authenticating local users on the AP

  • 1
  • Question
  • Updated 4 years ago
  • Answered
Is there a way to authenticate local users without the AP acting as a RADIUS server? I would like to have a few of my APs grab DHCP addresses but if it is acting as a RADIUS server then it has to have a static address configured. I can't seem to find another way to authenticate local users. 

Thanks.
Photo of Tom

Tom

  • 5 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of James Forbes

James Forbes

  • 11 Posts
  • 6 Reply Likes
You could try doing this with PPSK instead. PPSK allows you to create a unique WPA/WPA2 password for each user. This way you can identify each user individually and have a unique login / password for each user and not use a RADIUS server.



You will need to create a Local User Group under Configuration-->Authentication-->Local User Group. And local users within the group at Configuration-->Authenticatioin-->Local Users

Once the group is created and users for the group, you can apply it in the Network policy once PPSK is selected in the SSID:







Photo of Tom

Tom

  • 5 Posts
  • 0 Reply Likes
Hi James,

Thanks for the reply. That will work well for what I need. Thanks for taking the time to write out a reply. I just one more question. The option "Enable a captive web portal with use policy acceptance" is checked for me. Is that supposed to pop up a page after the user logs in to accept the user policy? I'm not seeing any other page after I give my credentials. Is there more configuration to get that work? 

Thanks,
Tom 
Photo of James Forbes

James Forbes

  • 11 Posts
  • 6 Reply Likes
Are the APs currently configured to use PPSK? If so, yes, the "Enable a captive web portal with use policy acceptance" should show a use policy acceptance CWP page once the user logs in with their PPSK password.

Photo of Roberto Casula

Roberto Casula, Champ

  • 231 Posts
  • 111 Reply Likes
You will need to configure and select a CWP for the SSID in the "Authentication" column under "Configure Interfaces & User Access". If this is left blank, the AUP CWP will not be displayed.
Photo of Tom

Tom

  • 5 Posts
  • 0 Reply Likes
Thank you James and Roberto. I was missing adding the CWP page in the authentication column.